Friday, February 19, 2021
yunohost@conference.lightwitch.org
February
Mon Tue Wed Thu Fri Sat Sun
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16 17 18 19
20
21
22
23
24 25 26
27
28
             
             
YunoHost support room | Don't ask to ask, just ask ! | Be patient and stay polite with everybody (this is a free software project ran by volunteers) | No answer? Post on the forum: https://forum.yunohost.org | This room is mirrored via Echo1 | Donate: https://liberapay.com/YunoHost

[11:16:02] <irc> <tigerbirdman> Hey all! I have a issue installing Hedgedoc. I couldn't find any open problems for this on the forum so I thought I'd try here first. I tried installing it twice now, both times it failed. These are the logs for the latest attempt:
[11:16:05] <irc> <tigerbirdman> https://paste.yunohost.org/raw/xecizevifo
[11:17:26] <irc> <tigerbirdman> Reading them it seems to me something is going wrong downloading sqlite3? and building it also fails? But I'm not experienced enough to say anything more then that based on the logs
[11:19:50] <irc> <tigerbirdman> Any hints to what I could do to fix this? I can log in on shell and can perform some basic tasks there, I could try installing sqlite3 from there for example?
[11:21:51] <irc> <eric_G[m]> The link to download sqlite3 seems broken: `2021-02-18 23:58:56,188: WARNING - node-pre-gyp WARN Tried to download(403): https://mapbox-node-binary.s3.amazonaws.com/sqlite3/v4.2.0/node-v83-linux-x64.tar.gz`
[11:47:56] <irc> <ox_mccattleson:matrix.org> just bumped into it on PH << https://www.producthunt.com/posts/yunohost-3
[12:38:13] <irc> <Dalvini> hello there, just tried to migrate a yunohost instance from stretch to buster
[12:38:21] <irc> <Dalvini> got the following error : https://paste.yunohost.org/raw/isabejejuv
[12:38:33] <irc> <Dalvini> now the web app gives a 500
[12:38:40] <irc> <Dalvini> I can still ssh and everything
[12:39:34] <irc> <Dalvini> (I tried to launch the migration again (# yunohost tools migrations migrate), still same error
[12:39:52] <irc> <Dalvini> can someone help me figure out how to fix this?
[13:19:24] <irc> <Guest68700> hey there, somebody any idea why installing luckysheet alwas ends in 502 Bad Gateway, when i try to reach it? i am quiet a noob, sorry
[13:21:45] <irc> <eric_G[m]> try installing testing: `sudo yunohost app install https://github.com/YunoHost-Apps/luckysheet_ynh/tree/testing `
[13:23:05] <irc> <Guest68700> thank you, will try
[13:24:15] <irc> <eric_G[m]> Luckysheet is Chinese language project ... It is quite difficult to get repo support upstream...
[13:25:36] <irc> <eric_G[m]> I had to google translate the config file comments... :/
[13:28:02] <irc> <Guest68700> still better than learing chianese i guess ;-)
[13:30:10] <irc> <eric_G[m]> Yes I guess. But then you still have to learn how to use Luckysheet 😭
[14:24:39] <irc> <titi12> hi, hope you are fine. I would like some help to configure the server yunothost. I can speak in english or french for describing my problem. Thank a lot
[14:26:20] <irc> <titi12> Ainsi, pouvez vous m'aider ?
[14:33:29] <irc> <chankalan> hello, a little PR for SPIP3.2.9 in yunohost : https://github.com/YunoHost-Apps/spip_ynh/pull/23
[14:35:17] <irc> <titi12> ma question est la suivante: j'ai branché le serveur yunohost (raspberry pi 4) derriere un modem routeur. En ouvrant les ports sur mon modem, cela ne fonctionne toujours pas. Il s'avère que le problème vient de Adresse IP Public car je ne peux pas accéder a nom de domaine que j'ai créé (ynh.fr). En contactant mon fournisseur d'accès, ce
[14:35:17] <irc> <titi12> dernier m'annonce un prix exorbitant pour avoir une adresse IP Statique ou dynamic. Pour cela je souhaite comprendre comment cela fonctionne et si vous auriez des pistes pour contourner ce problème ? et quel est la différence entre IP publique dynamique et statique ?
[14:35:20] <irc> <titi12> merci a vous
[14:35:49] <irc> <Aleks[m]> chankalan: si tu veux tu devrais pouvoir lancer un test en tapant !testme en commentaire sur la PR
[14:40:16] <irc> <chankalan> cool, c'est fait
[14:44:22] <irc> <chankalan> Aleks[m]: c'est quoi ce qui apparaît sous le commentaire "kay0u and others added 3 commits on 21 Dec 2020 "
[14:45:13] <irc> <Aleks[m]> c'est moi qui ai rechangé la branche cible en testing car c'est la bonne pratique ... du coup il a rebase des commits de la branche master dans ta branche et blbllblb mais c'est pas important
[14:45:40] <irc> <Aleks[m]> faudra juste qu'on pense bien à merger testing dans master une fois que la PR est validée
[14:47:20] <irc> <chankalan> ok, merci
[14:55:19] <irc> <titi12> personne ne peut m'aider concernant le problème énoncé plus haut ? Merci a vous
[14:57:04] <irc> <Aleks[m]> titi12: ebeheu normalement ton domaine ynh.fr est mis à jour toutes les 2 minutes si l'IP a changée .. je doute que ton IP dynamique change si souvent
[14:57:23] <irc> <Aleks[m]> donc quel est ton vrai probleme, qu'est-ce que dis l'écran de diagnostique
[14:57:38] <irc> <benc> un ip public est accessible depuis l'extérieur, une ipée privée non. une ip public dynamique va changer (redemarage de box) une statique ne changera pas
[14:58:20] <irc> <benc> il peut ne pas avoir de public ça se fait de plus en plus (en box 4G par exemple)
[15:03:46] <irc> <titi12> lorsque je lance le diagnostique, les plus gros problèmes viennent des ports 80, 443 etc.... il y a 8 ports qui ne sont pas ouvert et donc je ne peux accéder au "site internet" depuis l'extérieur. Seulement en local je peux accéder au serveur. J'ai bien fait les port forwarding au niveau du routeur. donc de ce coté la, je pense que tout est en
[15:03:46] <irc> <titi12> ordre. C'est pour cela que j'essaye de comprendre pourquoi cela ne fonctionne pas. J'ai contacter le fabricant du routeur qui a tester mon routeur. Il s'avère que je n'ai pas IP publique et donc que l'on ne peut avoir accès au serveur depuis internet. je chercher juste des pistes pour résoudre le problème. car j'ai vraiment aucune idée
[15:03:47] <irc> <titi12> pourquoi cela ne fonctionne pas. Merci a vous.
[15:05:31] <irc> <titi12> quand je vais sur mon nom de domaine et que je clique sur "visit", mon navigateur cherche et trouve rien. il y a pas de communication. Donc le problème vient des ports. et surtout de ce problème IP publique je pense.
[15:09:29] <irc> <tituspijean[m]> titi12: quel est ton fournisseur ?
[15:09:59] <irc> <titi12> je ne suis pas en france
[15:10:25] <irc> <tituspijean[m]> (Carrier-grade NAT? Port splitting?)
[15:10:40] <irc> <tituspijean[m]> titi12: ce n'est pas ma question 😇
[15:11:33] <irc> <titi12> j'ai déjà appeler mon fournisseur d'accès, il me propose une adresse IP publique fixe qui coute une fortune et une adresse IP publique dynamic qui coute moins cher mais je ne sais pas si cela va résoudre le problème
[15:13:02] <irc> <titi12> Le fournisseur est Tango
[15:13:19] <irc> <tituspijean[m]> Bon...
[15:13:19] <irc> <tituspijean[m]> L'IP publique dynamique va résoudre le problème, si tu arrives à confirmer avec eux que tu auras accès à tous tes ports.
[15:13:55] <irc> <Aleks[m]> comprends pas comment on peut vendre de l'internet sans IP publique ...
[15:14:06] <irc> <Aleks[m]> (ou bien c'est genre une IP partagée ?)
[15:14:16] <irc> <tituspijean[m]> Carrier-grade NAT and monies, je pense
[15:14:54] <irc> <tituspijean[m]> titi12: par quoi commence ton ip "publique" actuelle ?
[15:14:55] <irc> <tituspijean[m]> Genre les chiffres des deux premiers blocs? (111.222.333.444)
[15:16:13] <irc> <titi12> 94.252.XXX.XXX
[15:16:39] <irc> <tituspijean[m]> Ah mais non... peut-être qu'on verra l'IP du rougeur de l'isp... pas celle interne au NAT si s'en est un.
[15:17:28] <irc> <tituspijean[m]> titi12: ouais non désolé, ça n'aide pas à savoir ce que fout ton fournisseur d'accès :/
[15:17:47] <irc> <titi12> ba de se que je comprend, il bloque tout
[15:18:10] <irc> <titi12> et je dois payer chaque mois pour avoir accès a une IP publique dynamique
[15:20:13] <irc> <titi12> mais normalement si j'ai accès a tous les ports cela veut dire en gros que tous les ports seront ouvert et que donc je n'aurais aucun problème de ce coté la. si le port forwarding est bien fait sur mon routeur. plus de problème. Par contre si l'IP publique change, comment le nom de domaine ynh.fr va retrouver IP publique ?
[15:21:19] <irc> <tituspijean[m]> titi12: il y a une routine sur ton serveur qui se charge de mettre à jour les DNS (cf le message d'Aleks plus tôt)
[15:21:23] <irc> <titi12> autre question, mon routeur est programmé pour que toutes requêtes DNS passe par cloudflare, est ce que cela peut avoir un incidence quelconque ? Merci
[15:22:21] <irc> <Aleks[m]> mouarf ... si on commence à mélanger IP dynamique, IP-pas-vraiment-publique et cloudflare ... et DNS dynamique ...
[15:22:49] <irc> <Aleks[m]> à ce compte-là plutôt prendre un VPS directement plutôt que de créer un cyber-frankenstein
[15:23:15] <irc> <titi12> ok donc je vais mettre le tout en autonomatique pour les requêtes DNS.
[15:24:04] <irc> <titi12> Donc si je résumé: IP publique dynamique, DNS en automatique. et normalement tout devrait rouler
[15:24:08] <irc> <titi12> ?
[15:24:30] <irc> <tituspijean[m]> Aleks: cyber-frankenstein-zombie
[15:25:37] <irc> <Aleks[m]> titi12: j'imagine meme si je pige pas ce que tu veux dire par "DNS en automatique" ni ce que Cloudflare viens faire dans l'histoire ..
[15:27:30] <irc> <titi12> si je balance mes requêtes a travers cloudflare, mon ISP ne voit aucune de mes requêtes. Si c'est en autosomique sur mon routeur, toutes les requêtes DNS iront vers mon ISP directement qui se chargera de traiter la demande
[15:28:21] <irc> <titi12> automatique
[15:30:50] <irc> <titi12> exactement la même chose si on utilise quad9 par example
[15:30:50] <irc> <ynhuser> hi everyone. i run yunohost on my raspberry pi over tor. my shaarly give me
[15:31:41] <irc> <ynhuser> often this error: "You have been banned after too many failed login attempts. Try again later. " i tryed to turn off firewall, but don't seem working. any ideas?
[16:18:45] <irc> <chankalan> avec Nextcloud j'ai pas moyen de faire une synchronisation, d'où ça peut venir ?
[16:19:48] <irc> <tituspijean[m]> chankalan: c'est quoi l'erreur ?
[16:22:17] <irc> <chankalan> il manque le fichier .../flow ou queloque chose comme ça...
[16:24:25] <irc> <chankalan> index.php/login/flow
[16:25:00] <irc> <chankalan> page web indisponible
[16:25:14] <irc> <chankalan> faut dire que j'ai un vieux androïd en 4.4
[16:25:35] <irc> <chankalan> mais qui est synchronisé avec un autre nextcloud qui marche bien
[16:33:06] <irc> <tituspijean[m]> chankalan: est-ce que ton app Nextcloud est configurée comme étant publique ? (i.e. les visiteurs ont-ils accès?)
[17:06:03] <irc> <chankalan> tituspijean[m]: oui oui