Friday, August 28, 2020
yunohost@conference.lightwitch.org
August
Mon Tue Wed Thu Fri Sat Sun
          1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19 20
21
22
23
24
25
26
27
28
29
30
31
           
YunoHost support room | Don't ask to ask, just ask ! | Be patient and stay polite with everybody (this is a free software project ran by volunteers) | No answer? Post on the forum: https://forum.yunohost.org | This room is mirrored via Echo1 | Donate: https://liberapay.com/YunoHost

[08:03:39] <irc> <ynhuser|76529> Hi there
[08:04:01] <irc> <ynhuser|76529> I'm failing with installing a letsencrypt cert, could any body help? https://paste.yunohost.org/raw/afahusekuz
[11:22:12] <irc> <Aleks[m]> emile_: ouipe
[11:48:06] <irc> <yoan> Bonjour tout le monde, j'ai un soucis suite à une mise jour, système et applications. Le service php ne veut plus démarrer.
[11:49:48] <irc> <yoan> version yunohost 3.8.5.7. systemctl statuts php7.0-fpm.service donne une erreur avec piwigo
[11:50:10] <irc> <yoan> il se trouve que la mise à jour du système s'est bien passée, mais pas celle des applis : erreur sur piwigo
[11:50:42] <irc> <Aleks[m]> et donc, quelle est cette erreur à propos de piwigo dans php7.0-fpm
[11:50:53] <irc> <yoan> actuellement, cette appli semble avoir disparue, et je ne peux pas la réinstaller car le service php n'est pas en service
[11:51:04] <irc> <yoan> ERROR: [pool piwigo] the chdir path '/var/www/piwigo' does not exist
[11:52:08] <irc> <Aleks[m]> alright so let's delete that old php pool conf file .. not sure how that happens but not the first time I see that kind of stuff ... `rm /etc/php/7.0/fpm/pool.d/piwigo.conf`
[11:52:25] <irc> <Aleks[m]> then try to restart the service
[11:53:01] <irc> <yoan> it works !
[11:53:40] <irc> <Aleks[m]> a merde j'ai switché en anglais sans faire gaffe...
[11:53:40] <irc> <yoan> thanks a lot, i'll try to complete the updates..
[11:53:41] <irc> <Aleks[m]> cool!
[11:53:55] <irc> <yoan> je me disais aussi, tu avais l'air de bien comprendre le français ;)
[11:54:00] <irc> <Aleks[m]> ;P
[11:54:19] <irc> <yoan> quelle efficacité, je reste co sur ce forum un petit peu :)
[11:54:37] <irc> <Aleks[m]> c'est un peu la schyzophrénie du langage entre les gens en francais, les gens en anglais, et les messages d'erreurs en anglais
[11:55:08] <irc> <kidon[m]> d'ailleurs, il y a une préférence pour la langue quand on pose une question ?
[11:55:27] <irc> <kidon[m]> Il y a beaucoup de personnes qui ne parlent que anglais ?
[11:55:41] <irc> <Aleks[m]> celle qui te convient le mieux, meme si idéalement ce serait cool si tout le monde parlais anglais pour pas faire fuire les non francophones T_T
[11:56:29] <irc> <kidon[m]> Ok ! merci
[13:04:40] <irc> <jcverdie:matrix.org> Hi,
I came a few days ago with a CodiMD error during install which seemed to be related to memory. I've bumped my VPS to 4GB but I still get a fail: https://paste.yunohost.org/raw/besutowibo
[13:11:28] <irc> <Thatoo[m]1> J'ai cru lire sur le forum que les apps vpn-client et hot-spot wifi ne fonctionnaient pas sous yunohost 4, buster. C'est vrai?
[13:18:49] <irc> <Aleks[m]> Thatoo: non ... où est-ce que tu as lu ça ...
[13:19:53] <irc> <Aleks[m]> jcverdie: unfortunately that still looks like a memory issue though that's pretty frustrating ... but I ran some tests recently about codimd and concluded that it takes a peak of 3.5 GB of RAM during install (yes that's madness)
[13:19:56] <irc> <Aleks[m]> can you tell if you have other apps installed ?
[13:21:10] <irc> <jcverdie:chat.smart4.io> Yes Aleks I have a few. That's quite unfortunate indeed ☹️
[13:21:56] <irc> <Aleks[m]> well maybe temporary stopping heavy-consuming services may help
[13:22:41] <irc> <jcverdie:chat.smart4.io> I'm going to try with synapse and nextcloud stopped, good idea
[13:22:47] <irc> <jcverdie:chat.smart4.io> BRB... May be 😀
[13:25:57] <irc> <Aleks[m]> (or even stop php-fpm entirely)
[13:34:25] <irc> <Thatoo[m]1> <Aleks[m] "Thatoo: non ... où est-ce que tu"> J'ai du mal comprendre alors. Je ne saurais plus retrouver ça, j'ai parcouru le forum hier pour un autre sujet et je me suis dit qu'à l'occaz, il fallait que je me fasse confirmer/infirmer cette info.
[13:54:47] <irc> <jcverdie:chat.smart4.io> > <@yunohost:matrix.org> [irc] Aleks[m]: (or even stop php-fpm entirely)

stopping synapse was enough :)
[13:55:11] <irc> <jcverdie:chat.smart4.io> it looks like CodiMD package is quite old (v1.6) while the current release is 2.2 ? Did I miss something?
[13:56:17] <irc> <Aleks[m]> latest release here is 1.6 https://github.com/codimd/server/releases/tag/1.6.0
[13:56:19] <irc> <Aleks[m]> where do you see 2.2 ?
[13:57:06] <irc> <jcverdie:chat.smart4.io> ahem... https://hackmd.io/@codimd/release-notes/%2F%40codimd%2Fv2_2_0#Highlights
[13:57:36] <irc> <Aleks[m]> sounds like it's hackmd and not codimd ?
[13:57:51] <irc> <Aleks[m]> or maybe not
[13:57:59] <irc> <Aleks[m]> wtf
[13:58:02] <irc> <jcverdie:chat.smart4.io> it's hackmd website but it mentions codiMD, I'm confused
[13:58:17] <irc> <jcverdie:chat.smart4.io> (and actually I'm looking for features listed there such as csv preview and mindmap)
[13:58:40] <irc> <jcverdie:chat.smart4.io> > <@yunohost:matrix.org> [irc] Aleks[m]: wtf

Glad to see I'm not the only one to feel this way 😋
[13:59:01] <irc> <Aleks[m]> that makes no sense ... it's written codimd and there's a whole history but no mention of 1.6
[13:59:24] <irc> <jcverdie:chat.smart4.io> Unless it's something like official codiMD from hackMD vs forked codiMD?
[13:59:56] <irc> <Aleks[m]> yeah idk
[14:00:31] <irc> <Aleks[m]> https://github.com/hackmdio/codimd
[14:00:39] <irc> <Aleks[m]> indeed they have a repo named codimd
[14:00:41] <irc> <Aleks[m]> what the hell
[14:01:19] <irc> <jcverdie:chat.smart4.io> yes, with a release 2.2 https://github.com/hackmdio/codimd/releases/tag/2.2.0
[14:01:20] <irc> <Aleks[m]> ah
[14:01:45] <irc> <Aleks[m]> and the one we ship is https://github.com/codimd/server and it's written : Note: CodiMD is in the process of changing its name to HedgeDoc.
[14:01:53] <irc> <Aleks[m]> so what we're shipping is the future HedgeDoc
[14:02:13] <irc> <jcverdie:chat.smart4.io> which is trailing the release from hackmd (or not, or it's a total fork)
[14:02:46] <irc> <Aleks[m]> i don't know what's the best choice between shipping HedgeDoc or CodiMD-the-open-source-hackmd
[14:02:58] <irc> <Aleks[m]> Maybe eric_G has some hints about this ...
[14:04:19] <irc> <Aleks[m]> naively I don't like so much models with a company having a business around a software which provides an "open source" / community edition on the side so I'd rather stick with HedgeDoc
[14:04:29] <irc> <Aleks[m]> but that's because i'm a radical crypto-hippie
[14:05:06] <irc> <jcverdie:chat.smart4.io> As long as HedgeDoc keeps the pace that wouldn't be a problem, but feature-wise it doesn't seem true as we speak :(
[14:07:04] <irc> <Aleks[m]> well let's open an issue to discuss this
[14:08:37] <irc> <jcverdie:chat.smart4.io> Alex: https://github.com/hackmdio/codimd/issues/1219
[14:08:43] <irc> <jcverdie:chat.smart4.io> You'll find the explanation there
[14:08:50] <irc> <jcverdie:chat.smart4.io> (sort of)
[14:10:20] <irc> <jcverdie:chat.smart4.io> > <@yunohost:matrix.org> [irc] Aleks[m]: but that's because i'm a radical crypto-hippie

In fact you already have such things with gitlab. I think it's fine as long as there's no real hole created on purpose in the oss version, right?
[14:10:47] <irc> <Aleks[m]> yeah in fact CodiMD-the-open-source-hackmd is AGPL 3.0 so that's reassuring
[14:12:24] <irc> <Aleks[m]> ah interesting thread
[14:12:33] <irc> <Aleks[m]> apparently the hackmd team ain't so friendly
[14:13:25] <irc> <jcverdie:chat.smart4.io> FWIW, I came to #codimd:matrix.org to ask and here's the answer
[14:13:38] <irc> <jcverdie:chat.smart4.io>
[14:13:50] <irc> <jcverdie:chat.smart4.io> You're poised to chose one or another - or both :(
[14:24:53] <irc> <artyup> testing the irc with the irc sic client... http://tools.suckless.org/sic/
[14:34:33] <irc> <eric_G[m]> Aleks: HedgeDoc is the way
[14:34:46] <irc> <Aleks[m]> you have spoken
[14:35:47] <irc> <eric_G[m]> spoken I have
[14:36:41] <irc> <eric_G[m]> and I ended up making their new logo @.@
[14:41:09] <irc> <Aleks[m]> wut ? xD
[14:46:55] <irc> <katy> Hello !
[15:11:38] <irc> <kidon[m]> hello katy (if you have a question, just ask it, you may just have to wait after and not before)
[15:12:10] <irc> <katy> sure!
[15:26:27] <irc> <eric_G[m]> Aleks: https://community.codimd.org/t/time-to-find-the-hedgedoc-logo/171
[15:28:51] <irc> <Aleks[m]> nice :O
[16:59:44] <irc> http://im.yunohost.org/paste/93112528-5e25-4664-9894-3ea17c764ef8
[17:00:09] <irc> <Aleks[m]> well apparently etherpad gotta be upgraded somehow ...
[17:00:26] <irc> <Aleks[m]> i guess our app package is outdated maybe :|
[17:33:11] <roy> I just did the upgrade to buster from 3.8.5.7
[17:33:28] <roy> My internet failed just after it downloaded all the packages 😱
[17:34:42] <roy> Internet came back while installing said packages 😅
[17:35:18] <roy> And now it failed on migration 18 xtable to nftable
[17:36:00] <irc> <Aleks[m]> /o\
[17:36:08] <roy> Https://paste.yunohost.org/raw/lawuxoxoko
[17:36:56] <roy> I'm on a pi3
[17:37:03] <roy> > iptables/1.8.2 Failed to initialize nft: Protocol not supported
[17:37:12] <roy> This stood out to me
[17:38:15] <irc> <Aleks[m]> damned
[17:39:21] <irc> <Aleks[m]> I don't understand why nft/iptables ain't working on some RPi, it's supposed to just work ~_~
[17:39:34] <roy> I'm console it says the same when doing iptables -V
[17:39:41] <roy> In*
[17:39:45] <irc> <Aleks[m]> i guess in the meantime you can skip the migration but that's "not cool"™ because it means you have no firewall
[17:40:09] <irc> <Aleks[m]> if you're familiar with modprobe etc maybe there's something to load it
[17:40:14] <irc> <Aleks[m]> or investigate why it aint loaded
[17:40:22] <roy> Update-alternatives to iptables-legacy
[17:40:48] <roy> Now I'll run the migration agaon
[17:41:11] <roy> Fixed!
[17:42:37] <roy> Complete command that fixed it: update-alternatives --set iptables /usr/sbin/iptables-legacy

[17:44:15] <roy> My question now is,was that the final step?
[17:45:36] <irc> <OursBlanc> Aleks[m]: j'ai réparé mon serveur...
[17:45:44] <irc> <OursBlanc> le RJ45 était "un tout petit peu mal branché" malgré le clip
[17:45:50] <irc> <OursBlanc> donc forcément invisible sur le réseau
[17:45:52] <irc> <OursBlanc> grmblblbl
[17:46:25] <irc> <Aleks[m]> lelz...
[17:46:53] <irc> <OursBlanc> va faire une maj et un backup
[17:47:01] <irc> <OursBlanc> oui bon ça va hein... :p
[18:22:12] <irc> <elioat> Hey there -- I recent ran the migration and upgrade to the most recent version. All my apps are working a-okay, but I'm unable to reach the admin section. I see the pac-man loader forever. Does anyone have guidance on how to get around this issue?
[18:22:49] <irc> <elioat> as far as I can tell it has something to do with the yunohost api being unreachable?
[18:23:12] <irc> <Aleks[m]> ah yes, so let's first try to `systemctl restart yunohost-api` maybe
[18:23:33] <irc> <Aleks[m]> not sure why so many people report that kind of issue ... i don't understand why this specifically would happen
[18:24:26] <irc> <elioat> thanks! I'll give that a shot right now
[18:29:17] <irc> <elioat> Aleks[m] that did the trick!
[18:29:19] <irc> <elioat> thank you so much
[20:46:34] <irc> <_xs> Hello! J'aimerais savoir si c'est possible de re-créer la CA ssl générée à l'installation. Après un changement de domaine et regénération du certificat il garde l'ancien domaine pour la CA.
[20:46:45] <irc> <_xs> Provocant donc un mismatch pour le browser
[20:46:52] <irc> <_xs> Hello! J'aimerais savoir si c'est possible de re-créer la CA ssl générée à l'installation. Après un changement de domaine et regénération du certificat il garde l'ancien domaine pour la CA.
[20:47:01] <irc> <_xs> oups sorry pour le doublon
[21:01:40] <irc> <Aleks[m]> uuuh
[21:01:55] <irc> <Aleks[m]> pas sur que recréer la CA resolve ce soucis ...?
[21:02:22] <irc> <Aleks[m]> (pourquoi ne pas installer un certif letsencrypt?)
[21:09:03] <irc> <_xs> C'est prévu! pour l'instant c'est jute pour faire un test sur un LAN ^^ jme demandais quelle était la meilleure méthode pour regénérer la CA sans tout casser ^^'
[21:20:09] <irc> <ynhuser|77042> What is the default password (set by yunohost) in mysql for root ? CONTEXT: I wanted to restore a database backup in mysql, but found out I could not open mysql with root + my admin password. So I changed the root password in mysql (by temporarily skipping grant tables to get in). But now the automatic installer of yunohost cannot get in mysql (wro
[21:20:10] <irc> <ynhuser|77042> ng root password it seems).
[21:22:25] <irc> <_xs> Aleks[m]: Merci pour ton temps et tes réponse, je repasse très prochainement pour réfléchir sur le sujet avec toi/vous ^^ Bonne soirée :)
[21:59:43] <irc> <Aleks[m]> ynhuser|77042: mysql password is stored in /etc/yunohost/mysql