Monday, May 11, 2020
yunohost@conference.lightwitch.org
May
Mon Tue Wed Thu Fri Sat Sun
        1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30 31
             
YunoHost support room | Don't ask to ask, just ask ! | Be patient and stay polite with everybody (this is a free software project ran by volunteers) | No answer? Post on the forum: https://forum.yunohost.org | This room is mirrored via Echo1 | Donate: https://liberapay.com/YunoHost

[06:25:15] <irc> <pierre0412> bonjour o/
[09:08:40] <thierry> Bonjour a tous
[10:09:22] <irc> <autra[m]> Hi! Question about ynh users: they don't appear in /etc/passwd because they are handled by ldap, right?
[10:09:52] <irc> <kayou[m]> hi! exactly
[10:11:39] <irc> <autra[m]> thanks!
[10:12:18] <Gofannon> Hello, I cannot do backup anymore because the process is killed by the OOM killer. What could I do ?
[10:12:35] <irc> <autra[m]> I have just seen a forum somewhere on the internet saying "creating a user in ynh doesn't create it on the system", and I wanted to explain what's really going on
[10:12:47] <Gofannon> http://im.yunohost.org/paste/98fdd74f-3a7d-4ab7-9b3a-85804151f190
[10:14:24] <Gofannon> http://im.yunohost.org/paste/10a81d7d-e537-480f-b0df-f4ea4c237a50
[12:05:02] <irc> <Aleks_> Gofannon : uuuh wokay
[12:05:52] <irc> <Aleks_> well theoretically there's still a lot of available RAM ... but only 17 free + 0 RAM
[12:05:58] <irc> <Aleks_> uh 0 Swap*
[12:06:18] <irc> <Aleks_> so maybe that's the issue .... but I never really know how to interpret those
[12:28:01] <irc> <autra[m]> <Aleks_ "well theoretically there's still"> maybe Gofannon ran the free -m after the oom kill ?
[12:29:00] <Gofannon> Yes, command run after the OOM kill
[12:29:09] <irc> <autra[m]> Gofannon: I'm not an expert in those things either, but for 2GB ram, I'd put 2GB in swap too. It seems too low there. What's the hardware btw? (is the storage an sd card?)
[12:29:35] <Gofannon> Also, airsonic was killed a few days ago because of lack of RAM too (Thanks to new diagnosis dashboard :) )
[12:29:40] <irc> <autra[m]> so that's why you have a "lot" of free ram. But you swap is completely full, which is not a good sign
[12:30:04] <irc> <autra[m]> I'd say make it 2GB if you can
[12:30:29] <Gofannon> The box is a kimsuffi KS1, the smallest one
[12:30:30] <Gofannon> https://www.kimsufi.com/fr/serveurs.xml
[12:32:28] <Gofannon> Kernel is specific too, Ihad issues with nodejs apps. WIll switch kernel and how it behaves
[12:53:13] <Gofannon> Just added a 2Gb swapfile. I have 2,5 gb now
[13:21:16] <irc> <arthurdeprecq:robocoop.fr> Hi, i'm experiencing a strange behaviour on my server : i have a "matrix-user" "python-command" process using 25% of my RAM and a variable amount of CPU usage (10 to 80%). I wonder if this is normal as nobody is using the server currently. Could it be Synapse ?
[13:22:46] <irc> <arthurdeprecq:robocoop.fr>
[13:32:14] <irc> <mathijs:matrix.vgorcum.com> > <@arthurdeprecq:robocoop.fr> Hi, i'm experiencing a strange behaviour on my server : i have a "matrix-user" "python-command" process using 25% of my RAM and a variable amount of CPU usage (10 to 80%). I wonder if this is normal as nobody is using the server currently. Could it be Synapse ?

if you've joined large federated rooms synapse can be a bit resource hungry
[13:32:50] <irc> <mathijs:matrix.vgorcum.com> for reference, my synapse is usually using about 0.8-1.2 GB
[13:33:30] <irc> <mathijs:matrix.vgorcum.com> * for reference, my synapse is usually using about 0.8-1.2 GB RAM usage
[13:40:00] <irc> <arthurdeprecq:robocoop.fr> Well, i have a riot client on my laptop, from where I usually connect only to my private server chat. No contact with other federated rooms. I recently joined 2 big channels (including this one 😉). But as far as I understand, this happens on the client side. My Synapse instance is not supposed to host large rooms... Am I wrong somewhere ?
[13:42:12] <irc> <mathijs:matrix.vgorcum.com> that's not right: joining large rooms is definitely happening server-side
[13:43:24] <irc> <arthurdeprecq:robocoop.fr> ok, is it because i am connected with an account hosted on my server ?
[13:43:25] <irc> <mathijs:matrix.vgorcum.com> how much is 26.5% memory usage
[13:43:44] <irc> <mathijs:matrix.vgorcum.com> > <@arthurdeprecq:robocoop.fr> ok, is it because i am connected with an account hosted on my server ?

correct, and now your server is talking to all the other servers present in said rooms
[13:44:16] <irc> <arthurdeprecq:robocoop.fr> > <@mathijs:matrix.vgorcum.com> how much is 26.5% memory usage

something like 500MB
[13:44:39] <irc> <mathijs:matrix.vgorcum.com> that's fairly reasonable
[13:45:12] <irc> <mathijs:matrix.vgorcum.com> at least, for joining larger rooms
[13:45:16] <irc> <arthurdeprecq:robocoop.fr> yep but a huge difference with a little intern chat ^^
[13:45:50] <irc> <mathijs:matrix.vgorcum.com> of course
[13:47:35] <irc> <arthurdeprecq:robocoop.fr> In a world with a lot of decentralized servers, is the memory usage supposed to increase or to decrease ? Like, will my instance have to talk to more servers, or will the charge be better spread ?
[13:48:26] <irc> <arthurdeprecq:robocoop.fr> because that could be a problem for self-hosting 😕
[14:18:41] <irc> <jurcheck:matrix.org> onlyoffice is gone to level 0. when does it come back or must i install collabora. its a bit urgent to me, thats why i'm aksing
[14:23:37] <irc> <Aleks_> I think it's somewhat safe to install it ... currently our tests are failing because of the weird bug with rabbitmq-server which happens here and there ... it's not clear why/when it happens ... for many people it works just fine
[14:23:55] <irc> <Aleks_> in the best case scenario the install crashes but it will be cleaned up...
[14:24:06] <irc> <Aleks_> i mean worst case scenario*
[14:25:07] <irc> <Aleks_> jurcheck : so if you have a warning on the interface telling you you shouldnt install it, you can click Yes, because Aleks told you so ;P
[14:30:58] <irc> <jurcheck:matrix.org>
ok, lets go. many thx
[14:47:32] <irc> <jurcheck:matrix.org> works :D even yh says with strong words, dont do this, all went smooth many thx @aleks
[20:42:30] <irc> <Thatoo[m]> Bonsoir, est-il possible de brider l'envoi d'email? Plus particulièrement, est-il possible de brider l'envoi d'email vers certains domaines. Par exemple n'envoyer que 10 emails vers gmail à la fois puis attendre 15 min avant d'envoyer 10 autres emails... etc...?
[20:58:25] <irc> <Aleks_> Thatoo[m]: il me semble qu'il y a des reglages dans postfix oui, mais il va falloir potasser la doc et bricoler à la main
[21:19:10] <irc> <taziden> ça me fait penser qu'on pourrait livrer une conf par défaut là-dessus Aleks_
[21:19:17] <irc> <taziden> je me rends compte qu'il n'y a pas sur ma brique
[21:19:41] <irc> <taziden> il y a juste :
[21:19:42] <irc> <taziden> smtp_destination_concurrency_limit = 1
[21:19:46] <irc> <taziden> default_destination_rate_delay = 5s
[21:20:13] <irc> <plumf_:matrix.org> Bonsoir tous le monde, mais du coup ça sert à quoi de brider l'envoi d'email vers certains domaines ?
[21:20:58] <irc> <taziden> éviter d'être perçu comme source potentielle de spams
[21:22:19] <irc> <taziden> https://github.com/YunoHost/yunohost/blob/stretch-unstable/data/templates/postfix/main.cf#L172
[21:23:06] <irc> <taziden> actuellement, le serveur attend 5s entre chaque envoi à un même domaine
[21:24:43] <irc> <taziden> et l'autre réglage, ça indique qu'on envoie pas plus d'un seul mail à la fois par destinataire
[21:24:47] <irc> <taziden> on devrait plutôt mettre 2 tiens, pour que ça soit par domaine et pas par adresse de destination
[21:24:56] <irc> <taziden> http://www.postfix.org/postconf.5.html#default_destination_concurrency_limit
[21:25:52] <irc> <taziden> là, actuellement, on ne limite pas le nombre qu'on envoie en // à gmail par exemple
[21:27:36] <irc> <taziden> je suis bon pour faire une PR tiens
[21:28:10] <irc> <taziden> https://github.com/YunoHost/yunohost/pull/691
[21:29:04] <irc> <plumf_:matrix.org> Merci pour les explications
[21:40:18] <irc> <taziden> https://github.com/YunoHost/yunohost/pull/988 merci pour ta question Thatoo[m] :)
[21:53:55] <xaloc> http://im.yunohost.org/paste/12f297e7-334a-430f-b1f5-c69c5fa2dc43
[21:55:29] <xaloc> Merci :)
[21:58:49] <irc> <Aleks_> taziden: <3
[21:59:38] <irc> <Aleks_> xaloc : pas sur mais a mon avis ça ressemble furieusement au meme genre de soucis qu'avec jitsi ... peut-être que yalh aurait des pistes
[22:01:45] <irc> <yalh76[m]> @xaloc, c'est sur quelle app que tu as le probléem ?
[22:02:10] <xaloc> Conversations
[22:03:07] <irc> <yalh76[m]> t'asle lient vers le package ?
[22:03:18] <irc> <yalh76[m]> fatigué... t'as le lien vers le package ?
[22:04:00] <xaloc> Bon c'est avec metronome sur yunohost, conversations c'est le client
[22:04:12] <xaloc> Sur le portable, pardon…
[22:04:32] <irc> <yalh76[m]> Ah ok, je viens de comprendre...
[22:06:33] <irc> <yalh76[m]> pas le début d'une idée mais ça vaudrait le coup que tu remontes une issue sur le package metronome: https://github.com/maranda/metronome
[22:07:33] <irc> <yalh76[m]> t'as essayé avec un autre client xmpp pour voir si ça vient du client ou du serveur metronome ?
[22:12:25] <xaloc> Non je vais essayer merci et je remonterais l'issue si ça viens pas du client merci je vous tiens au courrant
[22:42:03] <irc> <Thatoo[m]> <taziden "https://github.com/YunoHost/yuno"> et bien de rien, je ne pensais pas faire autant de bruit, et je pensais que ma question était naïve... Comme quoi il vaut mieux toujours poser la questions
[22:49:29] <xaloc> Je fait un peut de test et ça ne marche pas avec le client web jappix de Yunohost ni avec pidgin. Du coup je pense que ça doit pas etre niveau client