Friday, January 31, 2020
yunohost@conference.lightwitch.org
January
Mon Tue Wed Thu Fri Sat Sun
    1 2 3 4 5
6 7 8 9 10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
   
             
YunoHost support room | Don't ask to ask, just ask ! | Be patient and stay polite with everybody (this is a free software project ran by volunteers) | No answer? Post on the forum: https://forum.yunohost.org | This room is mirrored via Echo1 | Donate: https://liberapay.com/YunoHost

[02:34:27] <irc> <kayou[m]> david - you want to package an app that use python 3.6?
[02:34:48] <irc> <kayou[m]> You can use venv I think
[02:35:00] <irc> <kayou[m]> Without any risk to break something
[02:35:37] <irc> <ej:homecore.space> Does anyone know where I can change the Mastodon outbound email address?
[06:05:11] <irc> <david:fediverso.net> > <@yunohost:matrix.org> [irc] kayou[m]: david - you want to package an app that use python 3.6?

Not package, just install and use in the same server where Yunohost is installed
[06:06:38] <irc> <david:fediverso.net> More specifically, I'd like to install this matrix-telegram bridge https://github.com/tulir/mautrix-telegram
[06:21:44] <irc> <kayou[m]> https://github.com/YunoHost-Apps/synapse_ynh/blob/testing/scripts/_common.sh
[06:22:08] <irc> <kayou[m]> Synapse already install python3, I think there is no problem then
[06:26:00] <irc> <david:fediverso.net> > <@yunohost:matrix.org> [irc] kayou[m]: Synapse already install python3, I think there is no problem then

But it has python 3.6, and the bridge requires 3.6
[06:26:10] <irc> <david:fediverso.net> * But it has python 3.5, and the bridge requires 3.6
[06:40:48] <irc> <kayou[m]> Damned
[06:40:52] <irc> <kayou[m]> Idk
[07:12:04] <irc> <jeroen:franssen.xyz> > <@yunohost:matrix.org> [irc] kayou[m]: Idk

you can run it in docker (the bridge)
[07:21:19] <irc> <jeroen:franssen.xyz>
[07:21:19] <irc> <jeroen:franssen.xyz> > <@liberodark:matrix.org> Merci d'avance de vos retours

fonctionne sans soucis...

[07:21:48] <irc> <jeroen:franssen.xyz>
[09:11:37] <irc> <madiwas> Bonjour je ne puis me connecter sur l'interface admin de YNH, j'ai le code d’erreur : SSL_ERROR_BAD_CERT_DOMAIN
[09:11:53] <irc> <madiwas> OK pour la CNX en SSH depuis mon terminal
[09:20:10] <irc> <JaXoM> et sur l'interface user, ca marche ?
[09:20:56] <irc> <JaXoM> si tu peux te logguer en ssh, p-e qu'il est temps de renouveler le certif. Tu uilises LetsEncrypt ?
[09:22:06] <irc> <madiwas> tout le domaine est OK, Oui j'utilise letsEncrypt, mais je ne sais pas comment renouveler les certificats en ligne de commande...
[09:33:47] <irc> <madiwas> OUPS ! Toutes les app sont KO et non OK !!!
[09:39:13] <irc> <madiwas> Y a-t-il une commande YNH pour renouveler les certificats ?
[10:09:51] <irc> <kayou[m]> madiwas: `yunohost domain cert-renew`
[10:10:05] <irc> <kayou[m]> -h si tu veux voir les différentes options
[10:10:23] <irc> <kayou[m]> --force --no-check si ça fail
[10:10:58] <irc> <kayou[m]> (no-checks, avec un "s")
[10:11:59] <irc> <madiwas> j'ai en retour Info: No certificate needs to be renewed.
[10:12:26] <irc> <madiwas> https://lyon-electricien.com/
[10:15:22] <irc> <kayou[m]> As tu essayé avec les options --force et --no-checks?
[10:18:34] <irc> <madiwas> J'ai fait un --force et tout est en vert dans la konsole mais pas sur le net
[10:19:57] <irc> <madiwas> Success! Successfully renewed Let's Encrypt certificate for domain lyon-electricien.com!
[10:23:13] <irc> <madiwas> Merci Mille fois Kayou ! J'ai trouvé mon PB
[10:23:45] <irc> <kayou[m]> C'était ça ou pas du tout?
[10:24:29] <irc> <madiwas> En fait l'administration de la BOX Bouygue à distance a été réinitialisé et il a changé le port que j'avais personnalisé par le 443
[10:24:58] <irc> <madiwas> du coup effectivement cela ne fonctionnait pas, BOX B de M