Tuesday, December 10, 2019
yunohost@conference.lightwitch.org
December
Mon Tue Wed Thu Fri Sat Sun
            1
2
3
4
5 6 7 8
9 10
11
12
13
14
15
16
17
18
19
20
21
22
23
24 25 26 27 28 29
30 31          
YunoHost support room | Don't ask to ask, just ask ! | Be patient and stay polite with everybody (this is a free software project ran by volunteers) | No answer? Post on the forum: https://forum.yunohost.org | This room is mirrored via Echo1 | Donate: https://liberapay.com/YunoHost

[00:05:55] <irc> <jump_spider:allgood.dev> Hello there. Having trouble logging into the user interface with sso. I can log into the admin interface just fine.
[00:20:16] <irc> <jump_spider:allgood.dev> huh, never mind, seems to be working now
[06:43:07] <irc> <Pierre0412> salut
[10:19:13] <irc> <reber> salut
[10:19:49] <irc> <reber> je me loggue avec le bon utilisateur et le bon mot de passe et ça retourne à l'écran d'authentification, une idée par hasard ?
[10:21:12] <irc> <reber> si je mets le mauvais utilsateur/mot de passe, ça met un message d'erreur. Sinon ça met pas de message d'erreur, mais il retourne à l'écran d'authentification et l'utilisateur n'est pas connecté du coup...
[10:22:25] <irc> <JaXoM> reber : j'ai déjà eu le souci sur Firefox, ça vient d'un problème de cache ou de cookies enregistrés... tu peux réessayer en navigation privée ?
[10:22:52] <irc> <reber> k
[10:23:28] <irc> <reber> 👍
[10:23:41] <irc> <reber> effectivement JaXoM ça marche sous chromium :) quand même étrange ...
[10:24:44] <irc> <JaXoM> j'avoue que la gestion des parcours sur les navigateurs, c'est un peu le bazar.
[10:25:15] <irc> <reber> je vais regarder si je peux clean le cookie de yuno
[10:27:33] <irc> <reber> j'ai effacé les cookies du site _et_ le cache, ça change rien ...
[10:28:24] <irc> <reber> j'ai essayé en navigation privée sous firefox, idem, même problème
[10:32:26] <irc> <reber> c'est quand même très étrange parce que tout se passe comme si la connexion se passait bien, et hop il revient à l'écran d'authentification
[12:53:55] <irc> <Bram> j'ai déjà vu ça quand tu te délogues de roundcube en utilisant le bouton de delog de roundcube au lieu de celui de yunohost
[14:04:15] <irc> <ej:homecore.space> Yunohost has been stuck restoring nextcloud from backup for multiple hours now. What can I do to cancel and try again?
[14:25:37] <irc> <JSL> if your nc install contained a lot of data that might be right though... check using lsof or iotop or something similar too see if it's stuck or just moving data
[16:08:46] <irc> <ej:homecore.space> JSL: it's only 12 gigs and I've left it overnight
[18:48:29] <irc> <Brainwasher> Bonsoir, j'ai un soucis depuis quelques jours que je n'arrive pas a régler par moi même. Je pense que le problème viens de nginx qui me dit "Faild to start a A High performance web server and a reverse proxy server" Avant d'essayer restaurer mon HDD par un clone plus ancien je me demandais si quelqu’un avait une solution moins "radical".
[18:51:58] <irc> <Brainwasher> Le problème se manifestant par une impossibilité d’accéder a mes services Yunohost, que ce soit la console d'administration, le portail ou les services. J'ai esayé via l'adresse IP local et cela ne fonctionne pas non plus
[19:10:28] <irc> <Brainwasher> Should i translate my post in english ? x)
[19:19:05] <irc> <oufmilo:matrix.travelpandas.eu> > <@yunohost:matrix.org> [irc] Brainwasher: Bonsoir, j'ai un soucis depuis quelques jours que je n'arrive pas a régler par moi même. Je pense que le problème viens de nginx qui me dit "Faild to start a A High performance web server and a reverse proxy server" Avant d'essayer restaurer mon HDD par un clone plus ancien je me demandais si quelqu’un avait une solution moins "radical".

Et quand tu redémarre nginx ?
[19:24:14] <irc> <Brainwasher> "Job for nginx.service failed because the control process exited with error code.See "systemctl status nginx.service" and "journalctl -xe" for details."
[19:28:40] <irc> <Brainwasher> Dans mes recherches j'ai vu qu'il y avait une histoire de port 80 aussi, et j'ai vu que j'avais apache2 actif sur ce port, mais comme je sais pas si c'est utile au fonctionnement de Yunohost donc pour l'instant je l'ai pas supprimé, mais j'ai essayé de réinstaller nginx et apache2 avec sudo apt
[19:37:35] <irc> <oufmilo:matrix.travelpandas.eu> > <@yunohost:matrix.org> [irc] Brainwasher: Dans mes recherches j'ai vu qu'il y avait une histoire de port 80 aussi, http://im.yunohost.org/paste/9a745740-d23e-4ec7-bfb8-19bf2e66185f
[19:38:29] <irc> <oufmilo:matrix.travelpandas.eu> En faisant un systemctl status nginx ça devrait te dire ou ça bloque
[19:43:27] <irc> <Brainwasher> Je crois bien, mais pas moyen de me souvenir ce que j'avais touché. Et "systemctl status nginx" je vois bien qu'il me dit que ca failed, comprends pas quel partie m'indique quel est le problème.
[19:45:41] <irc> <Brainwasher> Uploaded file: https://uploads.kiwiirc.com/files/06686a2ece7b06115e5004fc9f4b53b4/pasted.txt
[20:25:40] <irc> <oufmilo:matrix.travelpandas.eu> tu as essayer de redémarrer le service en faisant un systemctl restart nginx ?
[20:26:20] <irc> <oufmilo:matrix.travelpandas.eu> tu as essayé de redémarrer le service en faisant un systemctl restart nginx ?
[20:29:02] <irc> <Brainwasher> Non, je viens d'essayer, et il me dit "Job for nginx.service failed because the control process exited with error code"
[20:30:24] <irc> <Brainwasher> Mais je commence a me dire que je vais utiliser mon clone de disque et arrêter de vous embêter, ça en vaux surement pas la peine =)
[21:01:44] <irc> <oufmilo:matrix.travelpandas.eu> Ça ne m'embête pas mais je pense effectivement que c'est le mieux en général il vaut mieux éviter de toucher au config nginx avec yunohost lol
[21:06:46] <irc> <Aleks_> Brainwasher: tu ne peux pas avoir à la fois apache et nginx qui tournent ...
[21:06:56] <irc> <Aleks_> car tous les deux ont besoin du port 80
[21:10:12] <irc> <Brainwasher> Bon bah je pars la dessus alors ^^ Ok je regarderais sur ma backup si j'avais déjà apache2 ou si il s'est ajouté récemment.
[21:11:08] <irc> <Aleks_> si tu veux comprendre pourquoi il est installé, tu peux "apt install aptitude" puis "aptitude why apache2"
[21:11:23] <irc> <oufmilo:matrix.travelpandas.eu> > <@yunohost:matrix.org> [irc] Aleks_: Brainwasher: tu ne peux pas avoir à la fois apache et nginx qui tournent ...

Stopper le service apache peut résoudre le probleme
[21:12:00] <irc> <Aleks_> mais apache est succeptible d'etre relancé automatiquement au prochain reboot et va rebloquer nginx ...