Friday, October 18, 2019
yunohost@conference.lightwitch.org
October
Mon Tue Wed Thu Fri Sat Sun
  1 2 3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25 26 27
28 29 30 31      
             
YunoHost support room | Don't ask to ask, just ask ! | Be patient and stay polite with everybody (this is a free software project ran by volunteers) | No answer? Post on the forum: https://forum.yunohost.org | This room is mirrored via Echo1 | Donate: https://liberapay.com/YunoHost

[05:34:30] <irc> <Pierre0412> .3336salut
[08:17:43] <irc> <MadPanda[m]> portainer is not installable for me, see this log for further information
[08:17:47] <irc> <MadPanda[m]> https://paste.yunohost.org/raw/lujecinoqa
[12:52:30] <irc> <MadPanda[m]> is there any way to fix this?
[13:08:28] <irc> <nicofrand[m]> Dites, ça peut poser un souci à Yunohost si j'upgrade mon kernel ? J'ai actuellement un 3.16 et ça date, ça m'empêche notamment d'utiliser autre chose que devicemapper/aufs pour docker
[13:12:47] <irc> <nicofrand[m]> Je sais que yunohost ne prend pas en charge buster mais c'est "juste" debian 10 qui merdoie ou c'est lié au kernel ?
[13:16:53] <irc> <taziden> hello nicofrand[m] y'a rien qui merdoie, c'est juste qu'il faut adapter plein de choses parce que les versions logicielles changent, les configurations, etc etc
[13:17:09] <irc> <taziden> il faut tester comment se passe l'upgrade, écrire les scripts de migration, etc etc
[13:17:25] <irc> <taziden> (le kernel, au final, n'a pas d'importance)
[14:08:37] <irc> <reber> salut. Est ce que yunohost est censé pouvoir s'installer sur un Intel Celeron appolo lake ?
[14:09:09] <irc> <taziden> reber: il n'y a pas de raison qu'il ne puisse pas
[14:09:48] <irc> <reber> ok, ben alors il y en a au moins une parce qu'ici pas moyen, j'ai vraiment tout essayé au niveau de bios, et pas moyen :/
[14:10:30] <irc> <kayou[m]> C'est du x86 ça non?
[14:10:30] <irc> <reber> alors qu'une manjaro (amd64) par exemple passe sans soucis ...
[14:10:44] <irc> <kayou[m]> Ça devrait oui.
[14:10:49] <irc> <reber> oui ... mais vraiment pas moyen
[14:10:53] <irc> <reber> en fait ça boote pas
[14:10:54] <irc> <reber> sur l'iso
[14:11:25] <irc> <kayou[m]> Commence par installer un debian STRETCH (c'est important cette version) puis ensuite Yunohost
[14:11:46] <irc> <reber> debian j'ai pas essayé, mais là je suis parti sur une manjaro ...
[14:12:39] <irc> <kayou[m]> Ha, je suis pas certain pour l'ISO il y a quelques temps il y avait un souci avec la génération de l'ISO je ne sais pas si ça a été réglé depuis. Par contre en installant debian stretch, puis Yunohost par le Bash d'installation, ça doit se faire sans souci
[14:13:20] <irc> <kayou[m]> Yunohost n'est compatible que debian stretch
[14:13:38] <irc> <reber> https://www.ebay.fr/itm/AA-B4-Mini-PC-Quad-Core-5G-WiFi-BT4-0-8GB-192GB-Dual-Band-HDMI-N3450-for-Win10/163825206008
[14:13:45] <irc> <reber> c'est ce mini pc à 114 euros
[14:14:54] <irc> <reber> pas mal comme rapport qualité / prix sauf que l'iso boote pas effectivement ... Ca m'enchante moyen de tenter l'install d'une stretch mais bon à voir ...
[14:15:46] <irc> <reber> c'est pas dégueu en comparaison d'un raspi, là ya 8Go, un disque ssd de 250Go, et un mmc de 64 Go
[14:16:49] <irc> <reber> et un proc quadcore Intel Apollo N3450 quad core 2.2GHz,
[14:16:53] <irc> <nicofrand[m]> Vous savez si yunohost est compatible avec le kernel linux-image-4.9.0-11-amd64 ?
[14:18:47] <irc> <Aleks_> nicofrand[m]: yunohost se fiche un peu du kernel tant que le système tourne
[14:18:54] <irc> <kayou[m]> C'est vrai que c'est pas mal!
[14:19:09] <irc> <kayou[m]> Euh, j'imagine que oui. Je ne vois pas pourquoi ça ne le serait pas
[14:20:22] <irc> <nicofrand[m]> Aleks_: super merci, vu que yunohost ne gère pas buster j'ignorais si c'était lié au kernel aussi
[14:20:26] <irc> <nicofrand[m]> je vais faire la màj dans ce cas
[14:21:32] <irc> <Aleks_> nope, c'est + lié au changement de version de "tous les logiciels en meme temps", par exemple la monté de version de php ou postgresql...
[14:21:51] <irc> <Aleks_> (ou des librairies utilisées par Yunohost avec des changements qui pêtent la rétrocompat')
[14:22:52] <irc> <nicofrand[m]> très bien
[14:35:34] <irc> <MayeulC> L'install de Yunohost n'a pas fonctionné en UEFI pour moi.
[14:40:54] <irc> <nicofrand[m]> nickel, la màj du kernel semble être passé sans souci
[15:25:06] <irc> <reber> tant mieux
[15:25:36] <irc> <reber> si quelqu'un a l'explication ou le moyen de booter l'image yunohost depuis apollo lake hum... ça m'intéresse :)
[15:28:35] <irc> <nicofrand[m]> Devinez qui est le malin qui s'est dit "tiens je vais mettre /var/lib/docker sur ma partition /home car j'y ai + de place" et n'a pas pensé que ça serait backupé -_- ?
[15:29:11] <pierre.chevalier1967> Et paf, le disque de backup?
[15:30:54] <pierre.chevalier1967> Bonjouir, j'ai un petit souci, je voudrais installer un jitsi, mais ça merdoie.
[15:31:12] <irc> <nicofrand[m]> le disque non, je les fais sur borgbase.com
[15:31:27] <irc> <nicofrand[m]> j'ai pas encore regardé mais j'ai dû faire mal au quota
[15:31:41] <irc> <nicofrand[m]> et ça m'a bouffé pas mal de perf aussi
[15:31:43] <pierre.chevalier1967> Et paf, la facture?
[15:31:45] <irc> <nicofrand[m]> c'est comme ça que je l'ai vu d'ailleurs
[15:32:00] <pierre.chevalier1967> ;-)
[15:32:55] <pierre.chevalier1967> En fait, je ne suis pas sûr de vouloir installer jitsi: je souhaiterais avoir un outil de partage d'écran, via WebRTC, et j'osais espérer que jitsi fasse le job.
[15:33:11] <pierre.chevalier1967> Peut-être y aurait-il d'autres suggestions dans la salle?
[15:34:14] <pierre.chevalier1967> Je suis en train de regarder du côté des extensions à nextcloud. Talk ferait ça?
[15:44:52] <irc> <nicofrand[m]> bon ynh a pas trop aimé ma màj de kernel en fait. J'ai des "Une instance est déjà en cours d’exécution" sur l'interface web. J'ai tenté de redémarrer le service yunohost-api mais ça n'y fait rien. Une idée ? Ça s'affiche quand j'essaie de voir les domaines
[15:50:19] <irc> <taziden> tu as maj ton kernel comment (et pourquoi ?) ?
[15:51:49] <irc> <nicofrand[m]> j'ai installé linux-image-amd64 car je voulais pouvoir utiliser overlay(2) avec docker
[15:52:11] <irc> <nicofrand[m]> hm, ma requête web a fini par aboutir malgré l'erreur
[15:53:54] <irc> <nicofrand[m]> pourtant top n'affiche rien de spécifique, rien ne prend toutes les ressources
[15:55:20] <irc> <nicofrand[m]> bon, on va le laisser tranquille un moment et on verra si ça revient 🤷‍♂️
[16:02:00] <pierre.chevalier1967> "j'ai installé linux-image-amd64 car je voulais pouvoir utiliser overlay(2) avec docker"
=> il y avait quoi, avant, comme kernel?
[16:21:26] <irc> <Nicolas[m]2> Hello. Je crois avoir trouvé le pb qui explique le fait que je ne puisse pas me connecter à mon email depuis Thunderbird, je ne sais pas trop pourquoi mais le certificat utilisé pour mon domaine sur le port 993 n’est pas le bon, il utilise celui du domaine enregistré comme principal dans Yunohost. (obtenu *via* la commande `openssl s_client -connect domaine.tld:993`)
[16:26:36] <irc> <Nicolas[m]2> Dans `/var/log/mail.log` il me dit (entre autre) `SSL routines:ssl3_read_bytes:sslv3 alert bad certificate: SSL alert number 42` (ligne tronquée mais on comprend l’idée)
[16:30:01] <irc> <Aleks_> c.f. https://github.com/YunoHost/issues/issues/1301
[16:30:25] <irc> <Aleks_> probleme connu, pas de solution trivial, il faut trouver un moyen de faire accepter le certif à thunderbird
[16:31:35] <irc> <Aleks_> de ce que je comprends y'a pas de moyen techique dans les protocoles mail d'adapter le certif en fonction du domaine car ça se base surtout sur l'IP quand la connexion commence
[16:31:49] <irc> <Aleks_> (à la différence de HTTPS où y'a le SNI)
[16:31:56] <irc> <Aleks_> espère ne pas raconter trop de bêtises
[16:32:18] <irc> <Nicolas[m]2> Arf, ok je vois. 😕
[16:32:33] <irc> <MadPanda[m]> https://paste.yunohost.org/raw/lujecinoqa
[16:32:36] <irc> <MadPanda[m]> Aleks_ any idea what this could be?
[16:32:43] <irc> <Aleks_> ugh, docker :|
[16:35:10] <irc> <Aleks_> it fails here ... https://github.com/YunoHost-Apps/portainer_ynh/blob/master/scripts/_common.sh#L90-L99
[16:36:50] <irc> <Aleks_> Unable to find image 'portainer/portainer:1.19.2' locally
[16:36:53] <irc> <Aleks_> https://github.com/YunoHost-Apps/portainer_ynh/blob/master/scripts/docker/run.sh
[16:37:11] <irc> <Aleks_> well that's curious, your message mentions 1.19.2 but this script says 1.20.1 ...?
[16:37:46] <irc> <Aleks_> ah yeah the commit in the catalog is not up to date .. fun stuff
[16:38:31] <irc> <Aleks_> MadPanda[m]: can you try installing from https://github.com/YunoHost-Apps/portainer_ynh to get the fresh commit ?
[16:58:25] <anubis> pierre.chevalier1967, j'ai fait un test de partage d'écran avec Nextcloud/Talk, ça a l'air de bien fonctionner
[18:08:47] <irc> <reber> "nicofrand[m]" ?
[18:10:49] <irc> <reber> taziden, kayou[m] ah ben en fait oui mais non : https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=908852
[18:13:06] <irc> <reber> il semblerait que le bug vienne de stretch, il y a un fix, mais pas sûr que ça soit intégré. En tous cas yunohost ne l'a pas encore intégré
[18:13:42] <irc> <reber> Bien dommage parce que j'ai acheté ce pc juste pour mettre yunohost dessus, et avoir un peu plus de puissance qu'avec mon raspi ...
[18:14:13] <irc> <reber> devinez quoi ?
[18:14:26] <irc> <reber> Je suis bien dégouté ...
[18:15:23] <irc> <reber> (pour info pour ceux qui ont pas suivi, c'est pour mettre yunohost sur anglepc, un minipc à base de intel celeron apollo lake
[18:15:59] <irc> <Aleks_> le "brand new shiny stuff" effect :D
[18:20:41] <irc> <reber> heu non
[18:20:50] <irc> <reber> c'est pas si récent en fait, plus il est dans le placard depuis au moins 6 mois
[18:21:05] <irc> <reber> et j'étais motivé pour installé yuno, mais bon ... fail
[18:21:19] <irc> <Aleks_> ah ok :D
[18:30:46] <irc> <reber> *installer
[18:32:22] <irc> <reber> c'est quand que yunohost passe en debian stable ?
[18:35:11] <irc> <nicofrand[m]> <reber ""nicofrand[m]" ?"> Oui ?
[18:35:20] <irc> <nicofrand[m]> <yunobridge_ "<pierre.chevalier1967> => il y a"> 3.16
[18:35:46] <irc> <Aleks_> reber : quand les bénévoles auront donné suffisament de leur temps libre pour travailler gratuitement pour gérer le bordel technique de sorte à ce que ce soit facile et transparents pour les utilisateurs qui profitent de tout ça gratuitement ¯\_(ツ)_/¯
[18:49:17] <irc> <nicofrand[m]> hormis pour certaines apps hors yunohost, ça change pas grand chose pour l'utilisateur de toute façon, si ? Yunohost gère quasiment tout pour moi donc peu m'importe les nouveaux trucs si c'est pas lié à la perf
[18:49:53] <irc> <nicofrand[m]> au final debian 9 ou 10, je vois pas l'urgence : ça tourne
[18:52:55] <irc> <Aleks_> la grosse différence c'est par exemple la version de php
[18:53:10] <irc> <Aleks_> qui peut etre nécessaire pour installer certaines apps, par exemple dans nextcloud
[18:53:23] <irc> <Aleks_> (ou meme maintenant nextcloud râle d'etre en 7.0 je crois...)
[18:53:41] <irc> <Aleks_> mais sinon oui, ça change pas grand chose
[18:54:45] <irc> <Aleks_> enfin après il y a tout le fait que doucement mais surement par exemple les fournisseurs te proposent Debian Buster par defaut, ou alors en tant qu'user tu installes la derniere debian qui est Buster, en ayant l'intention d'installer un Yunohost ... pour au final te rendre compte qu'il faut réinstaller avec Stretch
[18:55:15] <irc> <Nicolas[m]2> Pour grav aussi PHP pose pb.
[18:56:58] <irc> <nicofrand[m]> en parlant de Nextcloud, vous seriez au courant d'un paramètre à régler pour faire fonctionner collabora online avec nextcloud ? J'ai suivi https://forum.yunohost.org/t/installer-collabora-avec-nextcloud/4768, l'install se fait bien, mais lorsque je tente d'afficher un odt dans nextcloud j'ai juste une page blanche (et une erreur js en console). Je sais pas où regarder
[19:02:33] <irc> <nicofrand[m]> hm, j'ai tenté un autre package yunohost sans docker, pas mieux
[19:03:00] <irc> <Aleks_> beh du coup je regarderais du côté de l'erreur js dans la console ...
[19:04:45] <irc> <nicofrand[m]> ouais mais c'est pas clair du tout. C'est minifié
[19:05:05] <irc> <nicofrand[m]> je vais chercher les logs côté nextcloud peut-être
[19:05:11] <irc> <Aleks_> l'erreur est minifié...?
[19:10:22] <irc> <nicofrand[m]> "n is undefined"
[19:10:27] <irc> <nicofrand[m]> et quand je cherche à en savoir + c'est minifié
[19:11:49] <irc> <nicofrand[m]> uploaded an image: image.png (44KB) < https://matrix.org/_matrix/media/r0/download/matrix.nicofrand.eu/zHRLbyQwzUsNxmYEjwFXmhQZ >
[19:14:01] <irc> <Aleks_> hmoké
[19:14:04] <irc> <nicofrand[m]> déminifié via les devtools
[19:14:33] <irc> <Aleks_> ben perso jpense que ca ressemble quand meme bien à la bonne piste, mais il faudrait tirer sur la ficelle
[19:16:36] <irc> <nicofrand[m]> je redoute de passer 3 heures à débugger ça pour tomber sur une bête erreur réseau :p
[19:17:18] <irc> <nicofrand[m]> mais je trouve pas de logs nextcloud :/
[19:17:39] <irc> <nicofrand[m]> j'aurais espéré une erreur + claire de nextcloud
[19:24:19] <irc> <nicofrand[m]> côté client je vois aucune requête vers collabora.mondomaine.tld (domaine sur lequel je l'ai installé)
[19:24:25] <irc> <nicofrand[m]> ça me paraît déjà étrange… Tout se ferait côté serveur ?
[19:24:46] <irc> <Aleks_> aucune idée, you're the expert ¯\_(ツ)_/¯
[19:24:58] <irc> <Aleks_> tu peux aussi regarder dans l'onglet "Network" des outils de dev pour voir quels sont les requêtes faites
[19:25:04] <irc> <Aleks_> ('fin faut sans doute recharger la page)
[19:26:30] <irc> <nicofrand[m]> t.data = "{\"MessageId\": \"App_LoadingStatus\", \"Values\": {\"Status\": \"Timeout\"}}" ça part mal déjà (par contre t.parsed existe pas, souci dans le code à mon avis)
[19:29:31] <irc> <nicofrand[m]> justement, aucune vers le domaine de collabora
[19:34:10] <irc> <Aleks_> ptete que c'est pour ça que n est pas défini :P
[19:44:52] <irc> <nicofrand[m]> bin le timeout m'inquiète + mais j'aimerais savoir qui fait la requête si c'est pas le navigateur
[20:12:23] <irc> <nicofrand[m]> Aleks_: en tout cas le code JS est buggué :D. Ils prévoient un message d'erreur par défaut mais le gèrent mal
[20:18:59] <irc> <nicofrand[m]> ah bah ça vient de tomber en marche tiens
[20:20:09] <irc> <nicofrand[m]> comprend rien
[20:21:10] <irc> <Aleks_> :D
[20:21:16] <irc> <Aleks_> l'1forka!k
[20:21:28] <irc> <Aleks_> 1form@t!k*
[20:23:15] <irc> <nicofrand[m]> bon j'ai pas trouvé la source du code JS non minifié pour rapporter le bug, tant pis
[20:23:47] <irc> <nicofrand[m]> par contre ça me permet de lire des docs en effet mais à l'écriture y'a tellement de latence c'est inutilisable
[20:24:19] <irc> <nicofrand[m]> et mon serveur n'affiche pas de soucis de perf, j'sais pas trop ce qui peut causer ça
[20:26:04] <irc> <nicofrand[m]> dommage, c'était pas loin d'être magique
[21:20:54] <irc> <tobi:im.kabi.tk> what coud that be?
[21:21:05] <irc> http://im.yunohost.org/paste/976d4ea8-8f66-4615-9e99-32323a99a8d0
[21:22:09] <irc> <tobi:im.kabi.tk> the funkwhale-beat service is suddenly not starting