Wednesday, October 09, 2019
yunohost@conference.lightwitch.org
October
Mon Tue Wed Thu Fri Sat Sun
  1 2 3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25 26 27
28 29 30 31      
             
YunoHost support room | Don't ask to ask, just ask ! | Be patient and stay polite with everybody (this is a free software project ran by volunteers) | No answer? Post on the forum: https://forum.yunohost.org | This room is mirrored via Echo1 | Donate: https://liberapay.com/YunoHost

[04:17:17] <irc> <SiM[m]> Bizarre, impossible de mettre en place un virement bancaire mensuel vers le compte Yunohost (pourtant je suis aussi au crédit coop) : "Erreur : le compte à créditer n'est pas créditable" :o Du coup j'ai fait un virement unique, je verrai le mois prochain...
[05:58:13] <irc> <Pierre0412> bonjour
[08:16:14] <irc> <MadPanda[m]> Good Morning, i just wanted to activate upnp on my yunohost instance and get this error: https://pastebin.com/fB6qP0EE
[08:16:45] <irc> <MadPanda[m]> most recent version
[09:09:17] <irc> <decentral1se> MadPanda[m]: looks like a bug in the yunohost code :/
[09:13:53] <irc> <decentral1se> can you also paste the contents of your `yunohost firewall list` and also the /etc/yunohost/firewall.yml file
[09:18:19] <irc> <MadPanda[m]> sure, give me a minute
[09:20:25] <irc> <MadPanda[m]> any fast way to do this decentral1se ?
[09:25:49] <irc> <MadPanda[m]> https://mdpnd.ch/zerobin/?aee4b8399b181e49#o0uBnWkfzgmGpt/ksX5cbYrbGUtXEWlI7HhZD87XqSo= this is the firewall.yml
[09:26:39] <irc> <MadPanda[m]> https://mdpnd.ch/lutim/lWPAOjaw/hRzOJuyj.png
[09:54:31] <irc> <Aleks[m]> Hmyea I guess the upnp code hasnt been designed to handle port ranges MadPanda
[09:54:59] <irc> <Aleks[m]> Anyway the upnp code is completely fucked up in many ways right now
[09:57:10] <irc> <MadPanda[m]> well, in my understanding, a port range is not that hard to handle?
[09:57:26] <irc> <MadPanda[m]> it just needs to be defined that 1-5 means 1,2,3,4,5
[09:57:47] <irc> <MadPanda[m]> or am i wrong?
[10:07:32] <irc> <Aleks_> MadPanda[m]: it's not so hard to handle indeed, it's just that maybe the range handling was added after the initial code for upnp, and not propagated to it, and basically nobody took care of it for the past 5 years
[10:08:23] <irc> <Aleks_> but anyway there's at least 5 other reason why UPnP is ~broken in yunohost https://github.com/YunoHost/issues/issues/1463
[10:09:29] <irc> <decentral1se> right yep, let's log this one on that ticket too then
[10:09:38] <irc> <decentral1se> thanks madpanda
[15:12:37] <irc> <flavien> Bonjour. J'ai un vps chez OVH sur lequel j'ai Debian 9 et Yunohost pour une utilisation familiale de Nextcloud. J'ai un problème avec Nginx qui ne me permet pas d'accéder ni à YNH ni à Nextcloud. J'ai déjà réinstallé complètement tout le système mais au bout d'un certain temps (entre 1h et 2 semaines) ça rebugue. Une piste ? Merci.
[15:14:08] <irc> <Aleks_> hmben du coup pourquoi est-ce que ca ne te "permet pas d'accéder", qu'est-ce qu'il se passe, il y a un message d'erreur en particulier ?
[15:17:43] <irc> <flavien> je vois "NGINX s'est arrêté" et quand je rafraîchis la page j'ai cette page https://framapic.org/wvQRbYZhk217/gkppHyLRtzhd.png
[15:18:21] <irc> <Aleks_> hmmmokay, et quand tu tentes d'accéder à Nextcloud ?
[15:19:18] <irc> <flavien> j'ai la page "la connexion a echoué" de firefox...
[15:19:50] <irc> <flavien> il y a une procédure spéciale pour une install sur un vps ovh ?
[15:20:19] <irc> <Aleks_> non pas specialement, la procedure classique ...
[15:20:39] <irc> <flavien> j'ai suivi benoîtement la procédure classique
[15:20:43] <irc> <flavien> ah. bon.
[15:21:16] <irc> <Aleks_> tu saurais te connecter en ssh et faire un "systemctl status nginx" ?
[15:29:27] <irc> <flavien> le port 22 est bloqué
[15:29:57] <irc> <flavien> j'ai fait mes 3 tentatives de mdp sans succès :((
[15:30:03] <irc> <Aleks_> mouarf
[15:30:13] <irc> <flavien> bah je vais réinstaller
[15:30:24] <irc> <flavien> et la prochaine fois que ça plante je reviens...
[15:30:44] <irc> <flavien> et je me note la vérification de nginx en ssh !
[15:31:47] <irc> <flavien> j'ai également eu un bug de validation https avec nexcloud qui était bloqué par firefox
[15:31:55] <irc> <flavien> alors que ynh était accessible
[15:32:05] <irc> <flavien> à toutes fins utiles...
[15:32:45] <irc> <flavien> *nextcloud ;)
[15:34:15] <irc> <flavien> merci et bonne fin de journée...
[15:35:35] <irc> <Aleks_> certes menfin reinstaller juste pour ça cest un peu fastidieux et pas la super solution de ouf ...
[15:35:50] <irc> <Aleks_> si tu reinstalles à chaque fois qu'il y a ce genre de probleme tu vas y passer ta vie ..
[18:56:27] <irc> <tristan76> bonsoir à tous, si il y a du monde bien sur ...!?
[18:57:48] <irc> <tristan76> Je suis dans une phase pas très drôle, Je crois que d'après ce que j'ai lu sur la toile le hairpening de ma livebox 3 me gêne à accéder au serveur de mon pi en appelant mon ip publique
[18:58:49] <irc> <tristan76> avez vous une méthode de contournement ? ou alors une astuce quelconque ...
[18:59:03] <irc> <Aleks_> pour contourner le soucis tu peux imaginer bricoler le /etc/hosts comme décrit dans la derniere section de cette page https://yunohost.org/#/dns_local_network
[18:59:14] <irc> <tristan76> Bonsoir
[18:59:32] <irc> <tristan76> Merci pour ta rapide réponse
[18:59:53] <irc> <tristan76> C'est sur le bricolage du host est une astuce mai sle pb de l'ip dynamique reapparait
[19:00:42] <irc> <tristan76> je suis sous ovh mutualisé et j'utilise leur dyn pour le réadressage sur mon pi
[19:02:58] <irc> <tristan76> En fait j'avais fait un serveur qui fonctionnait terriblement bien sans yunohost...pas de hairpening ; mais déployer younohost sur mon pi m'a paru comme une révélation avec une logithèque précompilée...
[19:03:09] <irc> <Aleks_> pour le truc du /etc/hosts, il te faut utiliser l'ip locale, pas globale
[19:03:10] <irc> <tristan76> donc je suis passé en mode production
[19:04:06] <irc> <tristan76> d'accord...mais de l'extérieur je rentre comment ?
[19:04:18] <irc> <Pierre0412> le hairpening n empeche pas lexterieur d acceder a ton ynh
[19:04:41] <irc> <Pierre0412> si tu rediriges les ports necessaires sur ton ynh biensur
[19:04:50] <irc> <tristan76> j'ai un accès ssh de l'extérieur fonctionnel, mais le http ....comment dire bricole
[19:05:44] <irc> <tristan76> oui oui j'ai ouvert les ports de ma livebox3, mon serveur d'avant fonctionnait déjà comme ça
[19:06:32] <irc> <tristan76> redirection sur un appareil avec MAC particulier en prime
[19:07:25] <irc> <tristan76> en fait de l'extérieur j'ai accès à mon administration, mais pas à mon frontend ( utilisation )
[19:07:37] <irc> <tristan76> c'est con quand même non ?
[19:08:00] <irc> <Aleks_> est-ce que tu y accèdes bien via ton nom de domaine ?
[19:08:35] <irc> <tristan76> oui oui http://sousdomaine.monsite.fr
[19:08:57] <irc> <Aleks_> et donc il se passe quoi quand tu tentes d'accéder au portal SSO
[19:09:21] <irc> <tristan76> un sous domaine qui pointe bien vers mon ip publique et rediriger avec le dyn ovh en cas d echangement
[19:09:42] <irc> <tristan76> en fait il se passe.......rien.....timeout dépassé
[19:10:14] <irc> <Aleks_> donc il se passe quand meme quelque chose
[19:10:31] <irc> <Aleks_> et pour accéder à l'admin, tu procèdes comment, aussi avec le domaine ?
[19:10:35] <irc> <tristan76> c'est sur !!!!
[19:10:42] <irc> <tristan76> vu comme ça...
[19:10:45] <irc> <tristan76> c'est pas faux
[19:11:27] <irc> <tristan76> dernier essai, il y a une seconde "Le délai d’attente est dépassé"
[19:12:12] <irc> <tristan76> j'essaie le httpS://.....
[19:12:29] <irc> <tristan76> pas mieux....arfff
[19:13:01] <irc> <Aleks_> pour accéder à l'admin, tu procèdes comment, aussi avec le domaine ?
[19:13:52] <irc> <tristan76> bah non l'admin n'est qu'en local si j'ai bien tout compris, ou alors en terminal via SSH de l'extérieur
[19:14:19] <irc> <Aleks_> nope, tu peux y acceder aussi via tondomaine.tld/yunohost/admin theoriquement ...
[19:14:35] <irc> <Aleks_> mais du coup quand tu fais ces tests, c'est depuis l'interieur du réseau, ou depuis l'extérieur ?
[19:15:44] <irc> <tristan76> les deux, sur mon ubuntu et sur mon téléphone portable en 4G biensur
[19:16:30] <irc> <Aleks_> bon du coup déjà tu devrais mettre en application le bidule dans le /etc/hosts pour pouvoir contourner le probleme de hairpinning en local
[19:16:48] <irc> <Aleks_> et pour ce qui est de l'accès depuis l'extérieur, vérifier que ton domaine pointe bien sur la bonne IP et que la redirection est bonne également
[19:17:06] <irc> <Aleks_> par exemple tu peux utiliser https://www.whatsmydns.net/ pour valider que ton domaine pointe sur la bonne ip
[19:17:36] <irc> <tristan76> c'est sur et certain puisque mon serveur précédent, avant le drame je veux dire...., fonctionnait à plein
[19:17:51] <irc> <tristan76> mon accès depuis l'extérieur n'a pas changé
[19:18:32] <irc> <Aleks_> certes mais ton ip locale peut avoir changé, et donc il faut peut-être mettre à jour les redirections vers la nouvelle ip locale
[19:19:30] <irc> <tristan76> Ovh intègre à son offre un outil qui s'appelle DynHost pour faire le même job....et mon ip locale je l'ai bloquer dans la box vers mon raspberrypi
[19:20:19] <irc> <tristan76> et comme je paye l'offre ( haie ! haie ! haie ! ) j'utilise le produit....
[19:21:31] <irc> <tristan76> Merci pour ton outil de controle d'IP publique, c'est bon c'est bien mon ip actuelle
[19:21:49] <irc> <tristan76> mon http://sousdomaine
[19:22:15] <irc> <tristan76> mon http://sousdomaine.site.fr pointe bien vers mon ip publique
[19:22:52] <irc> <tristan76> je pense que cela doit être simple...à mon avis
[19:23:16] <irc> <tristan76> du genre un truc tout simple plein de bon sens mais que je ne vois pas pour l'instant
[19:24:35] <irc> <tristan76> t'inquiètes pas je vais fouillé la toile.....jour et nuit s'il le faut....enfin presque ! :)
[19:26:21] <irc> <tristan76> je vais démonter la livebox, soudé un moteur de carte graphique, la mettre en multi-thread et augmenté sa ROM. Puis je chargerais un OS libre.
[19:26:26] <irc> <tristan76> Souhaites moi bon courage !
[19:26:32] <irc> <tristan76> Merci pour tout
[19:26:59] <irc> <tristan76> bonne soirée
[19:47:24] <irc> <Pierre0412> question bête
[19:47:37] <irc> <Pierre0412> ton domaine.fr ou sous.domaine.fr
[19:47:43] <irc> <Pierre0412> tu las bien configuré dans ynh ?
[19:47:58] <irc> <Pierre0412> parceque nginx ne saura pas ou t envoyer si ce n est pas le cas
[20:00:39] <irc> <tristan76> ah bonsoir Pierre !
[20:01:33] <irc> <tristan76> Oui oui j'ai tout fait dans l'interface "Admin" --> donc relier à la config de Nginx....mais la question étai tptrès pertinente
[20:03:14] <irc> <tristan76> un petit "cat" en terminal de la config Nginx via ssh le confirme
[20:10:01] <irc> <tristan76> bonne soirée je vais faire Dodo...
[20:15:28] <irc> <Pierre0412> ok :)
[22:27:03] <irc> <brabo> heya. so the decentralized internet and privacy devroom at fosdem20 is happening. i see in the past years, someone of the yunohost community was part of the steering committee for this devroom. is anyone of the team up for helping select what is most relevant to the community at this time?
[22:29:45] <irc> <Aleks_> ping decentral1se ^ ;P
[22:49:48] <irc> <decentral1se> brabo: id be up for chatting about this, sure!
[22:51:41] <irc> <brabo> decentral1se: awesome!
[22:51:48] <irc> <brabo> decentral1se: mind to pm?
[22:53:48] <irc> <brabo> can do here too, but it may be offtopic :)