Wednesday, July 24, 2019
yunohost@conference.lightwitch.org
July
Mon Tue Wed Thu Fri Sat Sun
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
       
             
YunoHost support room | Don't ask to ask, just ask ! | Be patient and stay polite with everybody (this is a free software project ran by volunteers) | No answer? Post on the forum: https://forum.yunohost.org | This room is mirrored via Echo1 | Donate: https://liberapay.com/YunoHost

[09:27:59] <madtibo> bonjour
[09:29:14] <madtibo> je regardais pour l'intégration de umap_ynh et de fil ne aiguille, je suis arrivé sur le helper postgresql
[09:30:06] <madtibo> le helper « ynh_psql_test_if_first_run() » remplace le peer par de l'authentification avec password
[09:30:14] <madtibo> le mot de passe passe donc en texte clair
[09:30:51] <madtibo> je propose d'utiliser un authentification en transférant le mot de passe haché
[09:31:05] <madtibo> ça a beau être en local, ça ne mange pas de pain côté sécurité
[09:33:23] <madtibo> sinon, côté authentification postgresql, je me demandais pourquoi on ajoute un mot de passe à PostgreSQL dans « ynh_psql_test_if_first_run() »
[09:33:51] <madtibo> sur debian, on peut se connecter sans problème avec l'utilisateur postgres par la socket local sans mot de passe (mode peer)
[09:34:25] <madtibo> bref, je suis dispo pour travailler côté PostgreSQL s'il y a des besoins
[09:34:31] <madtibo> bonne journée !
[15:18:08] <irc> <KataSchtroumpf|1> Bonjour à tout ceux qui ne sont pas à la piscine. J'ai un "Yunohost encountered an internal error:/"
[15:20:18] <irc> <KataSchtroumpf|1> Voici ce que me donne le sso :
[15:23:27] <irc> <KataSchtroumpf|1> https://framabin.org/p/?466caccde7ec12d5#p/6+hNETMH3ZWVlhZIc4vLeQAmK+sMRgozA9eoKqGr0=
[15:25:00] <irc> <KataSchtroumpf|1> Il s'agit d'une Briq Neutrinet Lime 1 à jour. Il y a juste linux-image-next-sunxi/stretch, qui reste à la version 5.67
[15:26:01] <irc> <KataSchtroumpf|1> Je peux me connecter en local et en console
[15:26:09] <irc> <Bram> KataSchtroumpf|1: salut, tu as cette erreur où/comment ?
[15:26:30] <irc> <KataSchtroumpf|1> Quelqu'un saurait où je dois chercher? Merci ;-)
[15:26:30] <irc> <Bram> c'est une traduction qui manque mais je pensais qu'on avait foutu du code pour éviter que ça puisse crasher quoi que ce soit
[15:26:47] <irc> <Bram> (et c'est pas ta faute)
[15:27:00] <irc> <Bram> ah et t'es sur quelle version de yunohost ?
[15:27:29] <irc> <Bram> probablement pas la dernière, je vois le string pour la traduction dedans https://github.com/YunoHost/yunohost/search?q=log_corrupted_md_file&unscoped_q=log_corrupted_md_file
[15:28:23] <irc> <Bram> ah oui, je vois pourquoi ça peut bugger
[15:28:57] <irc> <KataSchtroumpf|1> J'ai yunohost 3.6.4.3
[15:29:44] <irc> <KataSchtroumpf|1> Yunohost-admin, Moulinette et ssowhat 3.6.4,
[15:29:51] <irc> <Bram> ah, étrange
[15:31:11] <irc> <KataSchtroumpf|1> Est-ce que ça pourrait venir du fait que j'ai déplacé /home sur un disque externe en USB?
[15:31:33] <irc> <Bram> tu utilises une langue particulière qui est pas le français/anglais ?
[15:31:35] <irc> <Bram> la trad est bien présente je ne comprend pas https://github.com/YunoHost/yunohost/blob/stretch-stable/locales/en.json#L237
[15:31:39] <irc> <Bram> KataSchtroumpf|1: très peut probable
[15:31:54] <irc> <KataSchtroumpf|1> Le frenche, tout ce qu'il a de plus Belge. ;-)
[15:32:20] <irc> <Bram> haha, on a pas encore le fr_be :p
[15:33:27] <irc> <KataSchtroumpf|1> C'est sûr, c'est un véritable scandale. Mais on doit pouvoir survivre à ça. :-D
[15:34:34] <irc> <Bram> @Bram │ KataSchtroumpf|1: salut, tu as cette erreur où/comment ? << ?
[15:34:34] <irc> <Bram> je te vois parler du sso
[15:35:47] <irc> <KataSchtroumpf|1> Je ne parviens pas à me connecter par le nom de domaine, alors je passe en local par un browser. À la page de connection en admin, j'obtiens le message
[15:37:01] <irc> <Bram> ok
[15:38:03] <irc> <KataSchtroumpf|1> Je viens de lancer yunohost service status et je vois que le vpn est "deactivating" status = stop
[15:39:44] <irc> <KataSchtroumpf|1> Le hotspot semble ok, pourtant, il apparaît dans les wifi possible mais ne me permet pas d'accéder au réseau
[15:40:24] <irc> <KataSchtroumpf|1> J'ai essayé systemctl ynh-vpnclient restart
[15:40:24] <irc> <KataSchtroumpf|1> Unknown operation ynh-vpnclient
[15:45:56] <irc> <Bram> et avec ynh_vpnclient ?
[15:46:27] <irc> <KataSchtroumpf|1> idem
[15:46:37] <irc> <Bram> tu peux aller voir dans /var/log/yunohost/yunohost-api.log vers la fin stp ? c'est probablement là que tu as les erreurs
[15:46:42] <irc> <Bram> ah oui non, tu t'es trompé dans l'ordre
[15:46:48] <irc> <Bram> systemctl restart ynh-vpnclient
[15:46:54] <irc> <Bram> le verbe est en deuxième position
[15:47:17] <irc> <KataSchtroumpf|1> La dyslexie...
[15:47:32] <irc> <KataSchtroumpf|1> Vpn est redémarré
[15:48:23] <irc> <Bram> le message d'erreur est pas hyper clair aussi
[15:48:58] <irc> <KataSchtroumpf|1> Il est toujours là. Y-a-t-il un log plus détaillé qqpart?
[15:50:29] <irc> <Bram> @Bram │ tu peux aller voir dans /var/log/yunohost/yunohost-api.log vers la fin stp ? c'est probablement là que tu as les erreurs
[15:50:50] <irc> <Bram> mais en fait ça va peut être pas changé grand chose
[15:50:54] <irc> <Bram> (désolé je suis au taff)
[15:51:01] <irc> <Bram> (je réfléchi à 15 trucs en même temps)
[15:51:30] <irc> <Bram> est-ce que tu peux faireun
[15:51:58] <irc> <Bram> "grep log_corrupted_md_file /vagrant/yunohost/locales/*.json
[15:51:58] <irc> <Bram> stp ?
[15:52:34] <irc> <KataSchtroumpf|1> j'ai déjà plein de ligne avec "moulinette.core translate - untranslated key 'log_user_update' for locale 'br'"
[15:53:05] <irc> <KataSchtroumpf|1> Brrr, ça fait froid dans le dos. Br c'est Brésilien ou Breton?
[15:54:06] <irc> <Bram> oui, c'est Brézil, et je me demande bien pourquoi tu as ça
[15:57:46] <irc> <KataSchtroumpf|1> En tous cas, y a pas de Brazil sur mon pc. Comment vérifier sur la briq?
[15:59:41] <irc> <KataSchtroumpf|1> locale -a me donne en-US.utf8
[16:01:05] <irc> <KataSchtroumpf|1> Et donc j'ai des erreurs du type : "ERROR moulinette.core translate - unable to retrieve key 'service_description_ynh-vpnclient' for default locale 'e$
[16:01:05] <irc> <KataSchtroumpf|1> None
[16:01:05] <irc> <KataSchtroumpf|1> Et donc, j'ai des trucs comme ceci :
[16:01:16] <irc> <KataSchtroumpf|1> ERROR moulinette.core translate - unable to retrieve key 'service_description_ynh-vpnclient' for default locale 'e$
[16:01:39] <irc> <KataSchtroumpf|1> ERROR moulinette.core translate - unable to retrieve key 'service_description_ynh-hotspot' for default locale 'en'
[16:02:51] <irc> <KataSchtroumpf|1> ERROR moulinette.core translate - Failed to format translatable string 'log_corrupted_md_file' with error: 'md_fil$
[16:03:06] <irc> <KataSchtroumpf|1> Traceback (most recent call last):
[16:03:16] <irc> <KataSchtroumpf|1> File "/usr/lib/python2.7/dist-packages/moulinette/core.py", line 104, in translate
[16:03:29] <irc> <KataSchtroumpf|1> File "/usr/lib/python2.7/dist-packages/moulinette/core.py", line 104, in translate
[16:03:42] <irc> <KataSchtroumpf|1> KeyError: 'md_file'
[16:06:02] <irc> <KataSchtroumpf|1> https://framabin.org/p/?cb9200c79032c863#uNVvxOLVfrgpDp2d3/nfsrtSAg5dv1VpFoVNd/meQoo=
[16:08:37] <irc> <Bram> apparemment
[16:08:59] <irc> <Bram> pour une raison inconnu, tu as des fichiers de traductions incomplets
[16:16:19] <irc> <KataSchtroumpf|1> Y-a-t-il un moyen de copier une traduction complète pour la mettre à la place de la fautive?
[16:16:52] <irc> <KataSchtroumpf|1> Remplacer le Brazil par une copie du En_US par exemple?
[16:17:36] <irc> <KataSchtroumpf|1> Pour tester le blocage
[16:21:36] <irc> <Bram> tu peux m'envoyer le résultat de cette commande stp ?
[16:21:38] <irc> <Bram> cat /vagrant/yunohost/locales/en.json | yunopaste
[16:21:40] <irc> <Bram> (et du grep aussi)
[16:22:52] <irc> <KataSchtroumpf|1> https://paste.yunohost.org/famejovovu
[16:22:55] <irc> <KataSchtroumpf|1> https://paste.yunohost.org/famejovovu
[16:23:37] <irc> <Bram> ah
[16:23:38] <irc> <Bram> et
[16:23:39] <irc> <Bram> rah zut non
[16:23:43] <irc> <Bram> quelle patate je fais x(
[16:26:50] <irc> <Bram> KataSchtroumpf|1: cat /usr/lib/moulinette/yunohost/locales/en.json | yunopaste
[16:28:29] <irc> <KataSchtroumpf|1> https://paste.yunohost.org/rahuxilehi
[16:30:00] <irc> <Bram> "log_corrupted_md_file": "The yaml metadata file associated with logs is corrupted: '{md_file}'",
[16:30:14] <irc> <Bram> ok, la chaine de traduction est bien là
[16:30:15] <irc> <Bram> je ne comprend pas
[16:31:20] <irc> <Bram> va falloir que je creuse, mais plus tard, désolé :/
[16:32:12] <irc> <KataSchtroumpf|1> C'est l'heure du Mojito! ;-)
[16:33:04] <irc> <KataSchtroumpf|1> Si y a des éléments que je peux rassembler pour aider à la comprenure, dis le moi.
[16:33:34] <irc> <KataSchtroumpf|1> En tout cas, merci de t'être penché sur mon blême par cette canicule !
[18:54:34] <irc> <gredin67:matrix.fdn.fr> Salut!
[18:56:16] <irc> <gredin67:matrix.fdn.fr> J'essaie de configurer un bot synapse pour whatsapp sur ma lime 2. Il s'agit de l'appservice https://github.com/tulir/mautrix-whatsapp
[18:57:50] <irc> <gredin67:matrix.fdn.fr> J'ai installé en suivant le wiki, les logs de mon synapse indiquent que le service essaie de s'enregistrer, donc les addresses et ports semblent bien configurés.
[18:59:28] <irc> <gredin67:matrix.fdn.fr> par contre les logs de l'appservice indiquent
[WARN] Failed to update bot avatar: unexpected end of JSON input
[19:00:10] <irc> <gredin67:matrix.fdn.fr> Je me demande s'il y a une configuration spécifique à yunohost qui pourrait causer ce problème de JSON
[19:03:56] <irc> <gredin67:matrix.fdn.fr> dans les log de synapse j'ai une erreur
Unrecognised appservice access token.
[19:05:28] <irc> <gredin67:matrix.fdn.fr> pourtant j'ai bien rajouté le fichier registration.yaml de l'appservice, yunohost app setting synapse app_service_config_files retourne :
/home/whatsappbot/registration.yaml
[19:07:03] <irc> <gredin67:matrix.fdn.fr> ou plutôt
/opt/mautrix-whatsapp/registration.yaml
[20:20:24] <irc> <MayeulC> I would need help (en français au besoin) with the following issue: I can't ssh in due to wrong permissions for my home directory, but I am not sure what those should be.
[20:20:25] <irc> <MayeulC> `Authentication refused: bad ownership or modes for directory /home/mayeul`
[20:21:26] <irc> <MayeulC> currently they sit at "rwxrwxr-x+"
[20:45:34] <irc> <Bram> MayeulC: possibly something like "drwxr-xr-x"
[20:45:37] <irc> <Bram> also check for ownership
[20:45:42] <irc> <Bram> it should be user:user
[20:45:56] <irc> <Bram> like chown -R mayeul:mayeul /home/mayeul
[20:47:16] <irc> <MayeulC> Bram: Yeah, that's the funny thing. The group ownership is a numeric value, I am not sure what that means. Possibly a LDAP mapping? (I'm not sure how to check)
[20:47:53] <irc> <MayeulC> But since every user has the same permissions and a numeric gid, I assumed this was default.
[20:48:05] <irc> <MayeulC> There are also ACLs giving write access to the nextcloud group
[20:48:31] <irc> <MayeulC> This might be due to the fact that I added a nextcloud share in my user directory at some point.
[20:48:32] <irc> <Bram> ah, it's a bug in our ldap I think
[20:48:51] <irc> <Bram> I remember Josué talking about that
[20:49:01] <irc> <Bram> ah, possibly yes
[20:51:37] <irc> <MayeulC> But I reverted that change, and only did it in my home directory, yet permissions are the same in the other users'directories.
[20:51:57] <irc> <Bram> meh :/
[20:52:14] <irc> <MayeulC> I am a bit afraid of changing group ownership, wouldn't that risk breaking something?
[20:52:19] <irc> <MayeulC> (though, to be fair, I could revert it)
[20:52:42] <irc> <Bram> look at the permissions of ~/.ssh and ~/.ssh/*
[20:52:48] <irc> <Bram> that might be it
[20:53:46] <irc> <MayeulC> Bram: Those were somehow changed before IIRC, but I set them back to 700. And sshd is explicitly complaining about ~
[20:54:44] <irc> <Bram> I'm not sure then, sorry :/
[20:54:54] <irc> <Bram> it's probably a weird mistake that we aren't seeing
[20:55:33] <irc> <MayeulC> (well, .ssh/{config,known_hosts} were 644, but I set them again to 600 to no avail)
[20:56:07] <irc> <MayeulC> okay, no problem. I think I will try to change ownership then.
[20:56:23] <irc> <MayeulC> How do you consult the LDAP directory for the user mappings, usually?
[20:56:48] <irc> <Bram> "ldapvi"
[20:56:52] <irc> <Bram> but I hate ldap ^^'
[20:58:42] <irc> <MayeulC> Well, according to "getent passwd", the gid is correct on my ~ 🤔
[21:00:31] <irc> <MayeulC> You said ownership should be user:user? I have no "username" groups, according to "getent group"
[21:02:30] <irc> <MayeulC> Well, the issue is quite strange. I'll just do a "chmod g-w ~" for now (it seems to work). I dont's think g+w is needed anyway.
[21:09:22] <irc> <Bram> meh, out of my knowledge for that part here, sorry :x
[22:41:22] <irc> <cannabiscannibal> I changed the first users email from admin@example.com to test@example.com as I was testing something, went to change it back to admin@example.com and got welcomed with the error of this email ius reserved for the first user. So I went to CLI and tried changing it there, same error.
[22:41:28] <irc> <cannabiscannibal> How can I override this to force the change?