Tuesday, January 01, 2019
yunohost@conference.lightwitch.org
January
Mon Tue Wed Thu Fri Sat Sun
  1
2 3 4 5 6
7 8
9
10
11
12
13
14
15
16
17
18
19 20
21
22
23
24
25
26
27
28 29 30 31      
             
YunoHost support room | Don't ask to ask, just ask ! | Be patient and stay polite with everybody (this is a free software project ran by volunteers) | No answer? Post on the forum: https://forum.yunohost.org | This room is mirrored via Echo1 | Donate: https://liberapay.com/YunoHost

[00:01:02] <butterflyoffire> J'ai une question, voici le log : Bonne année #YunoHost 🎉🎁✨ et meilleurs voeux :).
[00:16:51] <irc> <frju365:matrix.org> :D
[00:19:49] <butterflyoffire> ;) 😋
[05:57:36] <Neustradamus> Happy new year to all
[08:26:38] <irc> <silkevicious:matrix.org> Happy new year! :-)
[14:30:32] <folatt> Bonjour
[15:25:13] <irc> <LinuxVieLoisir> Bonjour je me permet de vous contactez car je dispose de yunohost d'installer sur un vps. Tout fonctionne très bien, site web etc.. Seulement je ne parviens pas à configurer mes mails. Mon nom de domaine est chez ovh et mon vps chez dedigo. J'ai configurer mes dns MX et txt sur ovh à l'aide de mon domaine integrer sur yunohost dans la rubrique conf
[15:25:13] <irc> <LinuxVieLoisir> iguration dns mais cela ne fonctionne pas et j'ai meme prix contact avec ovh et ils n'ont pas su me dire ce qu'il ne va pas.
[15:29:44] <irc> <Aleks_> qu'est-ce qui te fait dire que ça ne fonctionne pas ?
[15:30:40] <irc> <LinuxVieLoisir> Mon but est de me servir de thunderbird, j'ai tout rempli, mais cela ne veut pas se connecter
[15:31:57] <irc> <Aleks_> c'est à dire, genre tu restes bloqué sur cet ecran ? https://yunohost.org/images/thunderbird_config_2.png
[15:32:04] <irc> <Aleks_> (genre il n'accepte pas le mot de passe ?)
[15:32:21] <irc> <LinuxVieLoisir> Exactement
[15:33:09] <irc> <Aleks_> du coup j'imagine que tu t'es assuré d'utiliser le bon mot de passe ? :P
[15:33:26] <irc> <LinuxVieLoisir> Oui mes je pense que cela vient des dns
[15:34:27] <irc> <Aleks_> hm pour la config thunderbird a mon avis ça n'a pas trop de lien je pense
[15:34:43] <irc> <Aleks_> la conf DNS c'est surtout quand ton serveur relaie le mail vers un autre serveur
[15:35:28] <irc> <LinuxVieLoisir> J'aurais mal configurer l'utilisateur dans yunohost ?
[15:39:15] <irc> <LinuxVieLoisir> Voilà ma config : https://cloud.craftdestiny.ovh/index.php/s/C6noroyT49MaSfg
[15:45:27] <irc> <Aleks_> hmnope ça m'a l'air good...
[15:45:45] <irc> <Aleks_> jteste 2-3 trucs
[15:45:58] <irc> <LinuxVieLoisir> D'accord merci
[15:46:38] <irc> <Aleks_> du coup c'est vraiment l'étape "Checking password.." qui pose problème c'est ça ?
[15:46:58] <irc> <LinuxVieLoisir> Oui
[15:47:06] <irc> <Aleks_> genre t'as "Configuration could not be verified - is the username or password wrong?" (ou l'equivalent francais)
[15:49:37] <irc> <LinuxVieLoisir> https://cloud.craftdestiny.ovh/index.php/s/JAkXLiqGCpE5MAt
[15:49:51] <irc> <LinuxVieLoisir> https://cloud.craftdestiny.ovh/index.php/s/JELDsCnGDp4BcQd
[15:50:05] <irc> <LinuxVieLoisir> https://cloud.craftdestiny.ovh/index.php/s/EMGRfLmD6JdXJbe
[15:50:24] <irc> <Aleks_> ah mais il faut pas mettre admin@ en haut
[15:50:32] <irc> <Aleks_> utiliser directement esteban@
[15:51:12] <irc> <Aleks_> admin@ est "juste" un alias
[15:53:23] <irc> <LinuxVieLoisir> https://cloud.craftdestiny.ovh/index.php/s/SzjcL4TTKHDejkr
[15:53:28] <irc> <LinuxVieLoisir> C'est pareil
[15:54:57] <irc> <Aleks_> hmokay wait, tu es en quelle version de yunohost ? c'est un "vieux" serveur ?
[15:56:46] <irc> <LinuxVieLoisir> Debian9 / 3.3.3 (stable) xeon 3ghz 100go d'espace disque et 3go ram
[15:58:31] <irc> <Aleks_> ok, je crois que ta conf postfix est pas à jour (genre normalement pour le SMTP c'est censé etre STARTTLS et pas SSL)
[15:58:33] <irc> <liberodark:matrix.org> Salut a tous
[15:58:35] <irc> <Aleks_> bref du cop tente un :
[15:58:58] <irc> <Aleks_> yunohost service regen-conf postfix --dry-run -d
[15:59:06] <irc> <Aleks_> et si y'a rien qui t'inquiete, fait
[15:59:09] <irc> <Aleks_> yunohost service regen-conf postfix --force
[16:00:12] <irc> <Aleks_> ah mais ou alors l'autre possibilité c'est que l'identifiant en bas, marqué "tonusername@tondomaine.tld", c'est censé etre juste "tonusername"...
[16:00:26] <irc> <Aleks_> c.f. : https://yunohost.org/images/thunderbird_config_2.png
[16:00:53] <irc> <liberodark:matrix.org> PS : Aussi j'ai vu son serveur Yuno Alek il lui manque aussi le SSO
[16:01:12] <irc> <Aleks_> il lui manque le SSO ..?
[16:01:33] <irc> <liberodark:matrix.org> oui il a un bad gateway je crois
[16:01:49] <irc> <liberodark:matrix.org> aucune co en utilisateur
[16:02:11] <irc> <liberodark:matrix.org> il a que l'interface admin
[16:02:39] <irc> <Aleks_> x_x
[16:03:31] <irc> <liberodark:matrix.org> Il m'avait demander pour la conf mail mais c'est pas mon truc donc je lui est recommandé de venir ici
[16:03:33] <irc> <LinuxVieLoisir> https://cloud.craftdestiny.ovh/index.php/s/dToSADXokBEmHTq
[16:04:11] <irc> <liberodark:matrix.org> il a 3 apps de mémoire
[16:04:43] <irc> <Aleks_> z'avez pas touché à /etc/ssowat/conf.json.persistent par hasard ?
[16:04:52] <irc> <liberodark:matrix.org> moi non
[16:04:52] <irc> <Aleks_> ou a la conf nginx ?
[16:04:58] <irc> <liberodark:matrix.org> non plus
[16:05:09] <irc> <LinuxVieLoisir> https://cloud.craftdestiny.ovh/index.php/s/Cj54RLBrKxJgxiA
[16:05:17] <irc> <liberodark:matrix.org> je lui est recommendé uniquement de mettre ça config DNS sur ovh
[16:05:21] <irc> <liberodark:matrix.org> sauf le xmp
[16:05:27] <irc> <liberodark:matrix.org> et le wildcard
[16:06:34] <irc> <Aleks_> bon, qu'est-ce que ça raconte un "yunohost service regen-conf" ?
[16:06:45] <irc> <OursBlanc_> bonjour ; je suis en train d'installer une instance yunohost sur un olimex lime 2 ; quel est le mot de passe par défaut et le login par défaut svp ?
[16:07:44] <irc> <Aleks_> tu as téléchargé l'image préinstallée, OursBlanc_ ?
[16:08:03] <irc> <Aleks_> apriori c'est root/yunohost
[16:08:16] <irc> <liberodark:matrix.org> c'est en cours...
[16:08:25] <irc> <liberodark:matrix.org> yunohost service regen-conf
Success! The configuration has been updated for service 'dnsmasq'
dnsmasq:
applied:
/etc/resolv.dnsmasq.conf:
status: updated
pending:

[16:08:34] <irc> <liberodark:matrix.org> Fini
[16:08:51] <irc> <OursBlanc_> Aleks_, j'ai peut etre pas flashé la bonne image je viens de voir que j'ai ARMbian sur la carte
[16:08:54] <irc> <OursBlanc_> faut donc installer par dessus
[16:09:21] <irc> <OursBlanc_> hm
[16:09:24] <irc> <OursBlanc_> je vais voir
[16:11:14] <irc> <liberodark:matrix.org> https://craftdestiny.ovh/yunohost/sso/
[16:11:26] <irc> <liberodark:matrix.org> fait un 404 page not found
[16:11:56] <irc> <Aleks_> liberodark : pas toi ... LinuxVieLoisir
[16:12:10] <irc> <liberodark:matrix.org> je l'aide sur son serveur pour pas qu'il soit perdu perso on utilise le meme hebergeur et je n'est aucun de c'est soucis
[16:12:15] <irc> <Aleks_> OursBlanc_: non, c'est normale d'avoir du armbian
[16:12:24] <irc> <Aleks_> les images préinstallées sont "juste" armbian avec yunohost déjà installé dessus
[16:12:33] <irc> <liberodark:matrix.org> Je lui est fait la commend en SSH pour lui je l'aide c'est la réponse de son serveur
[16:12:37] <irc> <Aleks_> si tu as téléchargé ton image depuis https://yunohost.org/#/images_en alors c'est bon
[16:12:38] <irc> <OursBlanc_> dac
[16:12:40] <irc> <OursBlanc_> oui o ui
[16:13:40] <irc> <Aleks_> liberodark : ok... du coup, est-ce que /etc/ssowat/conf.json.persistent contient quelque chose ?
[16:13:52] <irc> <liberodark:matrix.org> je check
[16:14:04] <irc> <liberodark:matrix.org> {
"redirected_urls": {}
}


[16:14:16] <irc> <liberodark:matrix.org> Voici le contenu
[16:14:33] <irc> <OursBlanc_> question à deux milliards de rouble afghan : ca change qqch d'accéder à son serveur par ipv6 ou par ipv4?
[16:16:19] <irc> <Aleks_> OursBlanc_: pas grand chose tant que ça marche, mais en utilisant l'ipv6 tu promeut le turfu qui devrait être le présent depuis 10 ans ;P
[16:17:03] <irc> <OursBlanc_> Aleks_, ca j'me doute :p
[16:17:32] <irc> <OursBlanc_> j'parlais avec un collégue russe (rien à voir) mais il été étonné en arrivant en france que genre la fibre : ben y'en a pas partout et que les débits sont tout pourri
[16:17:42] <irc> <OursBlanc_> (en adsl j'entends)
[16:17:48] <irc> <OursBlanc_> donc dix ans de retard voila quoi :p
[16:18:49] <irc> <OursBlanc_> et deuxieme question à huit milliard de rouble : il paraitrait qu'on peut faire un scan IP avec putty. c'est vrai ça ? si oui comment ?
[16:19:39] <irc> <Aleks_> un scan IP ?
[16:19:41] <irc> <Aleks_> c'est à dire ?
[16:19:47] <irc> <liberodark:matrix.org> Autre chose à voir ?
[16:21:18] <irc> <Aleks_> liberodark : beeeh nope .. mais naivement je dirais que c'est genre une app installée à la racine qui interfere avec d'autres trucs
[16:21:30] <irc> <Aleks_> (enfin avec l'url du sso en particulier)
[16:21:33] <irc> <liberodark:matrix.org> Yep
[16:21:47] <irc> <liberodark:matrix.org> Custom Web App
[16:21:52] <irc> <liberodark:matrix.org> Nexcloud
[16:21:54] <irc> <liberodark:matrix.org> Roundcube
[16:21:58] <irc> <liberodark:matrix.org> Wordpress
[16:22:07] <irc> <liberodark:matrix.org> Voilà
[16:22:20] <irc> <Aleks_> certe mais quelle est celle installée à la racine ...
[16:22:28] <irc> <liberodark:matrix.org> WP

[16:22:34] <irc> <OursBlanc_> Aleks_, lister tous les ip sur 192.168.1.0 a 192.168.1.255
[16:22:37] <irc> <OursBlanc_> et dire si ca pointe sur qqch
[16:22:59] <irc> <liberodark:matrix.org> Moi j'ai aucun soucis avec cela mais on pourrait refaire ça
[16:23:33] <irc> <Aleks_> ben du coup je reinstallerait nextcloud sur un chemin qui n'est pas la racine du domaine, et potentiellement configuré une redirection de / vers /blog ou un truc du genre, plutot qu'avoir le wordpress directement à la racine
[16:23:35] <irc> <liberodark:matrix.org> Mais bon sont gros soucis c'est les email
[16:24:23] <irc> <liberodark:matrix.org> le mieux est de lui ajouter un domain principal
[16:24:34] <irc> <liberodark:matrix.org> yuno.craft machin
[16:24:38] <irc> <Aleks_> yep ben c't'histoire d'email c'est chelou ... mais peut-être lié ... en tout cas une solution de contournement devrait pouvoir etre de faire "Configuration manuelle" dans le bidule de thunderbird et de remplir les champs comme sur https://yunohost.org/email_configure_client
[16:24:40] <irc> <liberodark:matrix.org> et de le définir par défaut
[16:25:27] <irc> <Aleks_> OursBlanc_: ouai ca s'apelle un ARP-scan, aucune idée de si on peut faire ça avec putty mais tu peux le faire avec la console windows en tout cas
[16:29:46] <irc> <liberodark:matrix.org> corrigé
[16:29:53] <irc> <liberodark:matrix.org> pour l'interface utilisateur
[16:29:57] <irc> <liberodark:matrix.org> reste les mail
[16:30:12] <irc> <OursBlanc_> comment fait on avec la console windows Aleks_ ?
[16:32:12] <irc> <LinuxVieLoisir> https://cloud.craftdestiny.ovh/index.php/s/RmGZQkKLBbJfYob => J'ai pourtant tout rempli comme il le faut
[16:36:04] <irc> <Aleks_> OursBlanc_: "arp -a" dans une console
[16:36:44] <irc> <Aleks_> LinuxVieLoisir: c'est STARTLS sur le port 587 pour SMTP
[16:36:59] <irc> <Aleks_> https://yunohost.org/images/thunderbird_config_2.png
[16:37:49] <irc> <OursBlanc_> bon maintenant je dois redigirer mes ports
[16:40:23] <irc> <LinuxVieLoisir> C'est bon ca fonctionne, merci beaucoup
[16:42:05] <irc> <OursBlanc_> pour ma redirection de port j'ai 4 trucs a remplir Adresse IP source / Plage de port / Adresse ip locale / Port local
[16:42:16] <irc> <OursBlanc_> si je comprends bien, la plage de port est la meme en source et en local
[16:42:22] <irc> <OursBlanc_> en ip source je met quoi ?
[16:42:25] <irc> <OursBlanc_> et en ip locale je met quoi ?
[16:45:03] <irc> <Aleks_> ip source je sais pas trop ... ça a pas moulte sens, c'est censé etre "tout", donc naivement je laisserais vide
[16:45:10] <irc> <Aleks_> et ip locale c'est l'ip locale de ton serveur
[16:48:28] <irc> <OursBlanc_> d'accord
[16:48:44] <irc> <OursBlanc_> j'arrive plus à me connecter en SSH voila aut'chose !
[16:52:26] <irc> <OursBlanc_> c'est normal ça ?
[16:55:40] <irc> <OursBlanc_> "connection time out"
[16:56:47] <irc> <Aleks_> beeeh, nope ... mais comment est-ce que tu fais, qu'est-ce que tu as changé par rapport à avant, etc...
[16:58:15] <irc> <OursBlanc_> ben pas grand chose en fait
[16:58:22] <irc> <OursBlanc_> dois je réinstaller mon instance ?
[16:58:30] <irc> <Aleks_> non...
[16:58:38] <irc> <Aleks_> comment est-ce que tu fais pour te connecter en ssh ...
[16:58:41] <irc> <OursBlanc_> putty
[16:58:44] <irc> <OursBlanc_> port 22
[16:58:48] <irc> <OursBlanc_> adresse du serveur en ipv4
[16:58:56] <irc> <Aleks_> et tu es sur de l'adresse ?
[17:00:04] <irc> <OursBlanc_> oui
[17:00:11] <irc> <OursBlanc_> la meme que l'interface admin web
[17:00:15] <irc> <OursBlanc_> je reboot
[17:06:59] <irc> <OursBlanc_> bon j'ai reboot ca a l'air d'aller
[17:07:48] <irc> <OursBlanc_> ma boite étant compatible avec UPnP j'ai fait la commande qui va bien, cependant avec l'outil en ligne pour checker les ports ; j'ai tout qui apparait en rouge
[17:07:49] <irc> <OursBlanc_> faut reboot ?
[17:15:11] <irc> <Aleks_> hmnope, cet outil est pas forcément 100% fiable
[17:15:29] <irc> <Aleks_> le mieux c'est d'essayer depuis une autre connexion (externe à ton réseau local) que ton serveur est bien accessible
[17:15:38] <irc> <Aleks_> par exemple, depuis un smartphone en 3g/4g
[19:49:28] <irc> <OursBlanc> rebonsoir
[19:49:43] <irc> <OursBlanc> pour info y'a un soucis dans l'install de jirafeau on peut pas laisser le champs password vide